summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorAlbert Cheng <acheng@hdfgroup.org>2010-08-06 19:32:23 (GMT)
committerAlbert Cheng <acheng@hdfgroup.org>2010-08-06 19:32:23 (GMT)
commit36e716eda0317c475bc1be0e4065c3e61f29b451 (patch)
treebe7268081a25da0131aa3b30696b1ed9aa72ec41 /configure.in
parent6d22b60931821fd2d3e020f347fa44bd5e520959 (diff)
downloadhdf5-36e716eda0317c475bc1be0e4065c3e61f29b451.zip
hdf5-36e716eda0317c475bc1be0e4065c3e61f29b451.tar.gz
hdf5-36e716eda0317c475bc1be0e4065c3e61f29b451.tar.bz2
[svn-r19185] Bug fix: ID 1917
In some machine (Linux), when --disable-largefile is used, it claims it has fseeko64 but off64_t is NOT supported. Moved the test of fseeko64 and ftello64 to where fseek64 is so that they are tested only if off64_t is supported. Tested: h5committested.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index 2961f38..c363ce5 100644
--- a/configure.in
+++ b/configure.in
@@ -1339,9 +1339,9 @@ CPPFLAGS="$AM_CPPFLAGS $CPPFLAGS"
AC_TRY_COMPILE([#include <sys/types.h>],
[off64_t n = 0;],
- [AC_CHECK_FUNCS([lseek64 fseek64 ftruncate64])],
- [AC_MSG_RESULT([skipping test for lseek64(), fseek64(), ftruncate64()])])
-AC_CHECK_FUNCS(fseeko fseeko64 ftello ftello64)
+ [AC_CHECK_FUNCS([lseek64 fseek64 fseeko64 ftello64 ftruncate64])],
+ [AC_MSG_RESULT([skipping test for lseek64(), fseek64(), fseeko64 , ftello64, ftruncate64() because off64_t is not defined])])
+AC_CHECK_FUNCS(fseeko ftello)
AC_TRY_COMPILE([
#include <sys/types.h>
#include <sys/stat.h>],