summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorBill Wendling <wendling@ncsa.uiuc.edu>2001-12-17 22:27:07 (GMT)
committerBill Wendling <wendling@ncsa.uiuc.edu>2001-12-17 22:27:07 (GMT)
commit4be3d608720c62e5b2afd0404f35d9001d7ed046 (patch)
tree699ad27c3d2be09412d1fe8da7415ee5fb37a388 /configure.in
parent971bc920b50eb7e0f8accfc1dbb95ad33ff6edcf (diff)
downloadhdf5-4be3d608720c62e5b2afd0404f35d9001d7ed046.zip
hdf5-4be3d608720c62e5b2afd0404f35d9001d7ed046.tar.gz
hdf5-4be3d608720c62e5b2afd0404f35d9001d7ed046.tar.bz2
[svn-r4730]
Purpose: Feature Fix Description: Have a better explanation of how to use the =DIR and =INC,LIB options for --with-xxx options. Solution: Created a phoney --with-fnord option whose only purpose it so supply us with the appropriate --help message. Platforms tested: Linux
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in20
1 files changed, 17 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index 69c57c9..523aa34 100644
--- a/configure.in
+++ b/configure.in
@@ -572,6 +572,22 @@ dnl Checkpoint the cache
AC_CACHE_SAVE
dnl ----------------------------------------------------------------------
+dnl Fake --with-xxx option to allow us to create a help message for the
+dnl following --with-xxx options which can take either a =DIR or =INC,LIB
+dnl specifier.
+dnl
+AC_ARG_WITH(fnord,
+ [
+ For the following --with-xxx options, you can specify where the header
+ files and libraries are in two different ways:
+
+ --with-xxx=INC,LIB - Specify individually the include directory and
+ library directory separated by a comma
+ --with-xxx=DIR - Specify only the directory which contains the
+ include/ and lib/ subdirectories
+ ],,)
+
+dnl ----------------------------------------------------------------------
dnl Is HDF4 present? If so then we can compile the hdf4 related tools.
dnl The HDF4 software has 4 component libraries (df, mfhdf, z, jpeg)
dnl and many header files. Will just verify the presence of mfhdf.h
@@ -604,9 +620,7 @@ AC_SUBST(H4TOH5TEST) H4TOH5TEST=h4toh5test
AC_SUBST(TESTH4TOH5) TESTH4TOH5='$(srcdir)/testh4toh5.sh'
AC_ARG_WITH(hdf4,
- [ --with-hdf4[=DIR] Use the HDF4 library where DIR is the directory
- containing the include/ and lib/ subdirectories which
- have the HDF4 header files and libraries [default=no]],,
+ [ --with-hdf4[=DIR] Use the HDF4 library [default=no]],,
withval=no)
case "$withval" in