summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorMike McGreevy <mamcgree@hdfgroup.org>2007-06-07 21:42:40 (GMT)
committerMike McGreevy <mamcgree@hdfgroup.org>2007-06-07 21:42:40 (GMT)
commit58c565aee7919f58de5f6de7a185c792e9e0a545 (patch)
treec86aeb9e846590e4fd73cc0f9381b9b052a27877 /configure.in
parentc80b7740130a31a3a9f91522988458393acc7288 (diff)
downloadhdf5-58c565aee7919f58de5f6de7a185c792e9e0a545.zip
hdf5-58c565aee7919f58de5f6de7a185c792e9e0a545.tar.gz
hdf5-58c565aee7919f58de5f6de7a185c792e9e0a545.tar.bz2
[svn-r13839] Purpose: creation of a DEFAULT_VFD macro in the test/Makefile.
Description: a new configure flag has been created that will now set a macro in the test/Makefile. The flag is with-default-vfd=. When set to a virtual file driver (e.g. "--with-default-vfd=sec2"), the macro DEFAULT_VFD will hold this value. Tested: kagiso, smirom, linew
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in20
1 files changed, 20 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 994e739..08ff399 100644
--- a/configure.in
+++ b/configure.in
@@ -2658,6 +2658,26 @@ if test 1 = 2; then
[Define if shared writing must be disabled (CodeWarrior only)])
fi
+dnl ----------------------------------------------------------------------
+dnl Check if user has provided a custom Virtual File Driver list
+dnl
+
+AC_MSG_CHECKING([for Default Virtual File Driver])
+
+AC_ARG_WITH([default-vfd],
+ [AC_HELP_STRING([--with-default-vfd=drivername],
+ [Define a default virtual file driver
+ [default=]])],,
+ withval=)
+
+AC_SUBST(DEFAULT_VFD_NAME) DEFAULT_VFD_NAME=${withval}
+
+if test -z ${withval}; then
+ AC_MSG_RESULT([no])
+else
+ AC_MSG_RESULT([yes])
+fi
+
dnl -----------------------------------------------------------------------------
dnl Should the Stream Virtual File Driver be compiled in ?
dnl