summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorElena Pourmal <epourmal@hdfgroup.org>2006-12-20 15:22:54 (GMT)
committerElena Pourmal <epourmal@hdfgroup.org>2006-12-20 15:22:54 (GMT)
commit6b156d43a9e66807a95f82280a5cc78047b12eaf (patch)
treeade21e381dcefbcb51bd9f7317b1ea485ab6d0f9 /configure.in
parentde9088b6bb7969aade23f5af0d1e4e1806fcc0c4 (diff)
downloadhdf5-6b156d43a9e66807a95f82280a5cc78047b12eaf.zip
hdf5-6b156d43a9e66807a95f82280a5cc78047b12eaf.tar.gz
hdf5-6b156d43a9e66807a95f82280a5cc78047b12eaf.tar.bz2
[svn-r13080] Description:
Maintenance for the HPUX 11.23 platform. Problem: C++ shared libraries are not supported for the 64bit mode (+DD64 compiler flag) Solution: Disable shared C++ library when +DD64 flag is detected. Platforms tested: sirius (HPUX 11.23 at UMKC) and kagiso
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index be8f2b4..d24dabc 100644
--- a/configure.in
+++ b/configure.in
@@ -791,6 +791,15 @@ if test "X${HDF_CXX}" = "Xyes" && test "X${enable_shared}" != "Xno"; then
H5_CXX_SHARED="no"
fi
+dnl Try to detect the +DD64 flag for HPUX aCC compiler and disable C++ shared libraries if it's
+dnl being used.
+
+ if (echo dummy ${CXX} ${CXXLD} ${CFLAGS} ${CXXFLAGS} ${LDFLAGS} | grep 'DD64') > /dev/null; then
+ echo " warning: +DD64 flag detected"
+ echo " disabling shared C++ libraries"
+ H5_CXX_SHARED="no"
+ fi
+
if test "X${enable_static}" = "Xno" && test "X${H5_CXX_SHARED}" = "Xno"; then
AC_MSG_ERROR([both static and shared C++ libraries are disabled])
fi