summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorRobb Matzke <matzke@llnl.gov>1999-03-18 13:42:52 (GMT)
committerRobb Matzke <matzke@llnl.gov>1999-03-18 13:42:52 (GMT)
commit826dbc81465d5d45cb96960ddeee97fb8b536f2d (patch)
treeee7e208308f918dd90d23ab64cdb793158efe4f3 /configure.in
parent4ec2ca72ba19629e76fe9de26f82119b0929b307 (diff)
downloadhdf5-826dbc81465d5d45cb96960ddeee97fb8b536f2d.zip
hdf5-826dbc81465d5d45cb96960ddeee97fb8b536f2d.tar.gz
hdf5-826dbc81465d5d45cb96960ddeee97fb8b536f2d.tar.bz2
[svn-r1149] ./configure.in
./configure [REGENERATED] ./src/H5config.h.in [REGENERATED] ./src/H5private.h Temporarily commented out the code that tries to link a simple MPI-IO application because I'm not sure how to pass $LDFLAGS and $LIBS to the compiler. Removed the `--enable-parallel=ibm' switch because the library we link with is either -lmpcc or -lmpcc_r but not both. The only way to tell is to see what compiler was specified (mpcc or mpcc_r) but if that compiler is specified then we don't need any libraries (the compiler script supplies them). That leaves just two choices: the user must use a compiler script: CC=mpcc ./configure or the user must state which library is desired: LDFLAGS='-lmpcc' ./configure --enable-parallel Checks for <setjmp.h>, longjmp(), and signal(). We don't check for setjmp() because it could be a macro (in fact, Posix requires it to be a macro) and if longjmp() is present then setjmp() is probably present too ;-) ./src/H5detect.c The alignment detection loop uses SIGBUS and setjmp/longjmp instead of fork/wait in order to get around bugs with forking in conjunction with mpich. This hasn't been tested on the SP-2 yet but it does work on the DEC Alpha. ./test/Makefile.in ./testpar/Makefile.in ./tools/Makefile.in Changed the order that libraries are linked so -lhdf5 is always before $LDFLAGS.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in20
1 files changed, 10 insertions, 10 deletions
diff --git a/configure.in b/configure.in
index 57cce1a..a6cad3f 100644
--- a/configure.in
+++ b/configure.in
@@ -172,7 +172,7 @@ AC_HEADER_STDC
AC_HEADER_TIME
dnl Unix
AC_CHECK_HEADERS(sys/resource.h sys/time.h unistd.h sys/ioctl.h sys/stat.h)
-AC_CHECK_HEADERS(stddef.h)
+AC_CHECK_HEADERS(stddef.h setjmp.h)
dnl Windows
AC_CHECK_HEADERS(io.h winsock.h sys/timeb.h)
@@ -386,7 +386,7 @@ dnl ----------------------------------------------------------------------
dnl How do we figure out the width of a tty in characters?
dnl
AC_CHECK_FUNCS(_getvideoconfig gettextinfo GetConsoleScreenBufferInfo)
-AC_CHECK_FUNCS(_scrsize ioctl compress2 setsysinfo)
+AC_CHECK_FUNCS(_scrsize ioctl)
AC_MSG_CHECKING(for struct videoconfig)
AC_TRY_COMPILE(,[struct videoconfig w; w.numtextcols=0;],
@@ -417,8 +417,8 @@ dnl ----------------------------------------------------------------------
dnl Check for functions.
dnl
AC_CHECK_FUNCS(getpwuid gethostname system getrusage fork waitpid)
-AC_CHECK_FUNCS(gettimeofday BSDgettimeofday difftime sigaction snprintf)
-
+AC_CHECK_FUNCS(gettimeofday BSDgettimeofday difftime snprintf)
+AC_CHECK_FUNCS(compress2 setsysinfo longjmp signal sigaction)
AC_TRY_COMPILE([#include<sys/types.h>],
[off64_t n = 0;],
AC_CHECK_FUNCS(lseek64 fseek64),
@@ -594,7 +594,7 @@ case "$CC_BASENAME" in
fi
;;
- mpcc)
+ mpcc|mpcc_r)
# The IBM compiler
PARALLEL=yes
;;
@@ -676,11 +676,11 @@ if test "X-" != "X-$PARALLEL"; then
AC_MSG_RESULT($RUNPARALLEL)
# Check that we can link a simple MPI and MPI-IO application
- AC_MSG_CHECKING(whether a simple MPI-IO program can be linked)
- AC_TRY_LINK(,[MPI_Init();MPI_File_open();],
- AC_MSG_RESULT(yes),
- AC_MSG_RESULT(no)
- AC_MSG_ERROR('unable to link a simple MPI-IO application'))
+dnl AC_MSG_CHECKING(whether a simple MPI-IO program can be linked)
+dnl AC_TRY_LINK(,[MPI_Init();MPI_File_open();],
+dnl AC_MSG_RESULT(yes),
+dnl AC_MSG_RESULT(no)
+dnl AC_MSG_ERROR('unable to link a simple MPI-IO application'))
# There *must* be some way to run in parallel even if it's just the