summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorJames Laird <jlaird@hdfgroup.org>2005-03-03 19:39:10 (GMT)
committerJames Laird <jlaird@hdfgroup.org>2005-03-03 19:39:10 (GMT)
commit965fef45d984b2ca0767fe5048e97a065254c3a1 (patch)
tree49daffb3f0e43797df345c4d3a0220931647ddcb /configure.in
parentf5c24bc9a46b989892e946bb6f440a88bb2f06af (diff)
downloadhdf5-965fef45d984b2ca0767fe5048e97a065254c3a1.zip
hdf5-965fef45d984b2ca0767fe5048e97a065254c3a1.tar.gz
hdf5-965fef45d984b2ca0767fe5048e97a065254c3a1.tar.bz2
[svn-r10132] Purpose:
Bug fix Description: When C flags are passed in using $CC variable, this can confuse test commands in configure (for instance, CC='pgcc -tp k8-32'). Solution: Previous solution didn't entirely solve problem. Wrote a sed snippit to strip flags from $CC for purposes of test in configure. Platforms tested: mir (just a configure bug)
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in7
1 files changed, 5 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index b6f5ba0..87fcd78 100644
--- a/configure.in
+++ b/configure.in
@@ -2771,12 +2771,15 @@ PARALLEL=${PARALLEL:-no}
dnl Compiler with version information. This consists of the full path
dnl name of the compiler and the reported version number.
AC_SUBST([CC_VERSION])
-if `echo $CC | grep / >/dev/null 2>&1`; then
+dnl Strip anything that looks like a flag off of $CC
+CC_NOFLAGS=`echo $CC | sed 's/ -.*//'`
+
+if `echo $CC_NOFLAGS | grep ^/ >/dev/null 2>&1`; then
CC_VERSION="$CC"
else
CC_VERSION="$CC";
for x in `echo $PATH | sed -e 's/:/ /g'`; do
- if test -x $x/$CC; then
+ if test -x $x/$CC_NOFLAG; then
CC_VERSION="$x/$CC"
break
fi