summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorAlbert Cheng <acheng@hdfgroup.org>2001-02-12 20:21:17 (GMT)
committerAlbert Cheng <acheng@hdfgroup.org>2001-02-12 20:21:17 (GMT)
commita9a7963c6642d9f31ea20cc1d9ce1e910fbc72b3 (patch)
treeb586ea4ca172ca99ba416d4accbceabcd25fdbf4 /configure.in
parentd7b92c34ebdd25b6088cc5a951f21bc0a125bb24 (diff)
downloadhdf5-a9a7963c6642d9f31ea20cc1d9ce1e910fbc72b3.zip
hdf5-a9a7963c6642d9f31ea20cc1d9ce1e910fbc72b3.tar.gz
hdf5-a9a7963c6642d9f31ea20cc1d9ce1e910fbc72b3.tar.bz2
[svn-r3401] Purpose:
[is this a bug fix? feature? ...] Description: Changed the default settings for enable-production and enable-debug to no and yes respective, for this development branch. Platforms tested: Modi4 parallel and eirene.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in8
1 files changed, 4 insertions, 4 deletions
diff --git a/configure.in b/configure.in
index 631cace..a87d3b0 100644
--- a/configure.in
+++ b/configure.in
@@ -365,13 +365,13 @@ AC_ARG_ENABLE(production,
[ --enable-production Determines how to run the compiler.])
case "X-$enable_production" in
- X-|X-yes)
+ X-yes)
AC_MSG_RESULT("production")
CONFIG_MODE=production
CFLAGS="$CFLAGS $PROD_CFLAGS"
CPPFLAGS="$CPPFLAGS $PROD_CPPFLAGS"
;;
- X-no)
+ X-|X-no)
AC_MSG_RESULT("development")
CONFIG_MODE=development
CFLAGS="$CFLAGS $DEBUG_CFLAGS"
@@ -1090,7 +1090,7 @@ AC_ARG_ENABLE(debug,
AC_SUBST(DEBUG_PKG)
all_packages="ac,b,d,e,f,g,hg,hl,i,mf,mm,o,p,s,t,v,z"
case "X-$DEBUG_PKG" in
- X-yes)
+ X-|X-yes)
DEBUG_PKG="d,e,f,g,hg,i,mm,o,p,s,t,v,z"
CPPFLAGS="$CPPFLAGS -UNDEBUG"
AC_MSG_RESULT(default ($DEBUG_PKG))
@@ -1100,7 +1100,7 @@ case "X-$DEBUG_PKG" in
CPPFLAGS="$CPPFLAGS -UNDEBUG"
AC_MSG_RESULT(all ($DEBUG_PKG))
;;
- X-|X-no|X-none)
+ X-no|X-none)
AC_MSG_RESULT(none)
DEBUG_PKG=
CPPFLAGS="$CPPFLAGS -DNDEBUG"