summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorRobb Matzke <matzke@llnl.gov>1997-08-28 16:36:57 (GMT)
committerRobb Matzke <matzke@llnl.gov>1997-08-28 16:36:57 (GMT)
commitae4e4231330459115827485b2896c992f904294d (patch)
treec8d326a5568abb3a946e7b75b491e80b68a7d392 /configure.in
parent31ff3e40a06c7d9cced2475f0e6e4acaa2afacd0 (diff)
downloadhdf5-ae4e4231330459115827485b2896c992f904294d.zip
hdf5-ae4e4231330459115827485b2896c992f904294d.tar.gz
hdf5-ae4e4231330459115827485b2896c992f904294d.tar.bz2
[svn-r43] *** empty log message ***
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in18
1 files changed, 17 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 8aea350..1d7ee2f 100644
--- a/configure.in
+++ b/configure.in
@@ -133,4 +133,20 @@ else
AC_SUBST(SETX) SETX="set -x"
fi
-AC_OUTPUT(config/depend config/commence config/conclude Makefile src/Makefile test/Makefile)
+dnl Where is the root of the source tree. Give an absolute address so
+dnl we can find it no matter which directory of the distribution is our
+dnl current directory. The built-in pwd fails on some systems, but the
+dnl /bin/pwd version works OK.
+if test -x /bin/pwd; then
+ pwd=/bin/pwd
+else
+ pwd=pwd
+fi
+AC_SUBST(ROOT) ROOT=`$pwd`
+
+dnl Touch the time-stamp files for src/H5config.h.in and src/H5config.h
+dnl before we generate them or the Makefiles.
+touch ./config/stamp1 ./config/stamp2
+
+AC_OUTPUT(config/depend config/commence config/conclude \
+ Makefile src/Makefile test/Makefile)