summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorMike McGreevy <mamcgree@hdfgroup.org>2008-05-15 21:35:13 (GMT)
committerMike McGreevy <mamcgree@hdfgroup.org>2008-05-15 21:35:13 (GMT)
commitafbdbb8e93d2b2d96098abfa4bf1615205487ca5 (patch)
treeebbac9b3bfbd0e5e5aca73b1c6c10ac1f57034c6 /configure.in
parent134ec13cdc933b5342c3d5fd8ca2ef5663af0df8 (diff)
downloadhdf5-afbdbb8e93d2b2d96098abfa4bf1615205487ca5.zip
hdf5-afbdbb8e93d2b2d96098abfa4bf1615205487ca5.tar.gz
hdf5-afbdbb8e93d2b2d96098abfa4bf1615205487ca5.tar.bz2
[svn-r15014] Purpose: Configure Macro Modification
Description: The macro H5_HAVE_WINDOW_PATH is now defined to 1 only when MinGW is in use. This is needed to fix the "links" test, and the external link feature in the library. Tested: kagiso
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in19
1 files changed, 10 insertions, 9 deletions
diff --git a/configure.in b/configure.in
index 19b3c4b..f8921e3 100644
--- a/configure.in
+++ b/configure.in
@@ -2895,16 +2895,17 @@ dnl (This flag should be _unset_ for all machines, except for Windows, where
dnl it's set in the custom Windows H5pubconf.h file)
dnl
AC_MSG_CHECKING([if the machine has window style path name])
-AC_CACHE_VAL([hdf5_have_window_path], [hdf5_have_window_path=no])
-
-if test ${hdf5_have_window_path} = "yes"; then
- AC_DEFINE([HAVE_WINDOW_PATH], [1],
- [Define if your system has window style path name.])
- AC_MSG_RESULT([true])
-else
- AC_MSG_RESULT([false])
-fi
+case "`uname`" in
+ MINGW*)
+ AC_DEFINE([HAVE_WINDOW_PATH], [1],
+ [Define if your system has window style path name.])
+ AC_MSG_RESULT([yes])
+ ;;
+ *)
+ AC_MSG_RESULT([no])
+ ;;
+esac
dnl -----------------------------------------------------------------------
dnl Set flag to indicate that the machine can handle conversion from