summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorRaymond Lu <songyulu@hdfgroup.org>2005-02-24 22:54:05 (GMT)
committerRaymond Lu <songyulu@hdfgroup.org>2005-02-24 22:54:05 (GMT)
commitb0c346caa201cdc5bf40a314910ac33c75ba8951 (patch)
tree808620c125a73088971c3b6291a58cb137593d79 /configure.in
parentb67493fcda5ffe9f51b65ee95ca23714b7d9a555 (diff)
downloadhdf5-b0c346caa201cdc5bf40a314910ac33c75ba8951.zip
hdf5-b0c346caa201cdc5bf40a314910ac33c75ba8951.tar.gz
hdf5-b0c346caa201cdc5bf40a314910ac33c75ba8951.tar.bz2
[svn-r10081] Purpose: Some Kind of Verification
Description: The library didn't handle incorrect hardware conversion for datatype. It simply did convert to incorrect data if any hardware didn't handle correctly. Solution: During configuration, incorrect hardware conversion is detected and some macros are defined. Use these macros to decide whether to register hardware conversion in H5T.c. If no hardware conversion function is registered for certain pair of datatypes, software conversion function will be used as the conversion path. Although slower than hardware conversion, we're more confident software conversion is accurate. So in one sentence to describe library's behavior, if some hardware conversion doesn't work well, software conversion will be used instead. Platforms tested: h5committest and fuss. Misc. update: some changes to configure's comments.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index ce8be8a..6b09d21 100644
--- a/configure.in
+++ b/configure.in
@@ -2618,7 +2618,7 @@ fi
if test ${hdf5_cv_sw_ulong_to_fp_bottom_bit_works} = "yes"; then
AC_DEFINE([SW_ULONG_TO_FP_BOTTOM_BIT_WORKS], [1],
- [Define if your system can accurately convert unsigned long long values to floating-point values.])
+ [Define if your system can accurately convert unsigned (long) long values to floating-point values.])
AC_MSG_RESULT([yes])
else
AC_MSG_RESULT([no])
@@ -2626,7 +2626,7 @@ fi
dnl ----------------------------------------------------------------------
dnl Set the flag to indicate that the machine can accurately convert
-dnl 'float' or 'double' to 'unsigned (long) long' values.
+dnl 'float' or 'double' to 'unsigned long long' values.
dnl (This flag should be set for all machines, except for PGI compiler
dnl where round-up happens when the fraction of float-point value is greater
dnl than 0.5.
@@ -2663,7 +2663,7 @@ fi
dnl ----------------------------------------------------------------------
dnl Set the flag to indicate that the machine can accurately convert
-dnl 'float', 'double' or 'long double' to 'unsigned (long) long' values.
+dnl 'float', 'double' or 'long double' to 'unsigned long long' values.
dnl (This flag should be set for all machines, except for HP-UX machines
dnl where the maximal number for unsigned long long is 0x7fffffffffffffff
dnl during conversion.