summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorBill Wendling <wendling@ncsa.uiuc.edu>2001-05-10 21:43:34 (GMT)
committerBill Wendling <wendling@ncsa.uiuc.edu>2001-05-10 21:43:34 (GMT)
commitce7c9f7b08114a3bd1e557f71b82eef27b223f96 (patch)
treeec583a8a7f538e2aaf3e59793990dd6dbfca3ae3 /configure.in
parente1a266b72e46e3eb352b4751533585afb3aadf80 (diff)
downloadhdf5-ce7c9f7b08114a3bd1e557f71b82eef27b223f96.zip
hdf5-ce7c9f7b08114a3bd1e557f71b82eef27b223f96.tar.gz
hdf5-ce7c9f7b08114a3bd1e557f71b82eef27b223f96.tar.bz2
[svn-r3906] Purpose:
Bug Fix Description: A parallel example was added to the examples/ subdirectory. This was being built whether --enable-parallel was defined or not. This was causing some havoc with certain setups. Solution: Added logic to make it so that the parallel examples are made only if --enable-parallel is specified. Platforms tested: Linux
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in4
1 files changed, 3 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 9feaa1a..1937629 100644
--- a/configure.in
+++ b/configure.in
@@ -1581,10 +1581,12 @@ touch ./config/stamp1
saved_no_create=$no_create
no_create=yes
-PARALLEL_MAKE=
+PARALLEL_MAKE=""
+AC_SUBST(PARALLEL_EXAMPLES_SRC) PARALLEL_EXAMPLES_SRC=""
if test -n "$TESTPARALLEL"; then
PARALLEL_MAKE="$TESTPARALLEL/Makefile"
+ PARALLEL_EXAMPLES_SRC="examples/ph5example.c"
fi
EXTRA_H4_MAKEFILES=