summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorQuincey Koziol <koziol@hdfgroup.org>2006-04-20 23:54:47 (GMT)
committerQuincey Koziol <koziol@hdfgroup.org>2006-04-20 23:54:47 (GMT)
commitd7573cbc857f5a2a843a42b3ea05cd9d3770208d (patch)
treef4e7afbb25303fdc587ab5d95b824ea77cb62407 /configure.in
parentad790bfa3c700de8ac49ebeaeffe0be1a876b6de (diff)
downloadhdf5-d7573cbc857f5a2a843a42b3ea05cd9d3770208d.zip
hdf5-d7573cbc857f5a2a843a42b3ea05cd9d3770208d.tar.gz
hdf5-d7573cbc857f5a2a843a42b3ea05cd9d3770208d.tar.bz2
[svn-r12292] Purpose:
Code maintenance Description: Remove flexible parallel code Platforms tested: FreeBSD 4.11 (sleipnir) Linux 2.4 (heping) Solaris 2.9 (shanti) Linux 2.4/64 (mir)
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in29
1 files changed, 0 insertions, 29 deletions
diff --git a/configure.in b/configure.in
index c332b38..3d913bd 100644
--- a/configure.in
+++ b/configure.in
@@ -2316,32 +2316,6 @@ if test -n "$PARALLEL"; then
fi
dnl ----------------------------------------------------------------------
- dnl Check if they would like the "Flexible parallel" interface enabled
- dnl
- AC_MSG_CHECKING([if Flexible Parallel HDF5 interface enabled])
- AC_ARG_ENABLE([fphdf5],
- [AC_HELP_STRING([--enable-fphdf5],
- [Enable the Flexible Parallel HDF5
- interface [default=no]])],
- [FPHDF5=$enableval],
- [FPHDF5="no"])
-
- if test "X$FPHDF5" = "Xyes"; then
-
- dnl The --enable-fphdf5 flag is not compatible with --enable-fortran.
- dnl If the user tried to specify both flags, throw an error.
- if test "X$${FPHDF5}" != "X" && test "X${HDF_FORTRAN}" != "X"; then
- AC_MSG_ERROR([--enable-fphdf5 and --enable-fortran flags are incompatible])
- fi
-
- AC_DEFINE(HAVE_FPHDF5, 1,
- [Define if we want flexible parallel HDF5 support])
- AC_MSG_RESULT([yes])
- else
- AC_MSG_RESULT([no])
- fi
-
- dnl ----------------------------------------------------------------------
dnl Set the flag to indicate that the MPI_File_set_size() function
dnl works with files over 2GB, unless it's already set in the cache.
dnl (This flag should be set for all machines, except for ASCI Red, where
@@ -3528,9 +3502,6 @@ PRINT "---------"
PRINT_N " dmalloc"
IF_YES_NO "$HAVE_DMALLOC"
-PRINT_N " Flexible Parallel HDF"
-IF_YES_NO "$FPHDF5"
-
PRINT_N " Function Stack Tracing"
IF_ENABLED_DISABLED "$FUNCSTACK"