summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorMike McGreevy <mamcgree@hdfgroup.org>2008-10-24 21:30:07 (GMT)
committerMike McGreevy <mamcgree@hdfgroup.org>2008-10-24 21:30:07 (GMT)
commitdc4434724c3f7b4031fafde9e734d47af0bb97a0 (patch)
tree47fb1775f50a376cf0c9f325dd4624031a9c22bf /configure.in
parentfb1499b60cbeb1932e7f612f57bfd29497c22e98 (diff)
downloadhdf5-dc4434724c3f7b4031fafde9e734d47af0bb97a0.zip
hdf5-dc4434724c3f7b4031fafde9e734d47af0bb97a0.tar.gz
hdf5-dc4434724c3f7b4031fafde9e734d47af0bb97a0.tar.bz2
[svn-r15947] Purpose: Bug Fix
Description: Adding the SZIP path to LD_LIBRARY_PATH within configure was inadvertently blowing away anything already in LD_LIBRARY_PATH. This fixes that, which solves, among other things, the problem where configure failed to learn how to print 'long long' on cobalt. Tested: full make check install: kagiso, smirom configure / make / h5ls test only : cobalt, linew
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in7
1 files changed, 6 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index b72b5e4..f758865 100644
--- a/configure.in
+++ b/configure.in
@@ -1676,8 +1676,13 @@ if test "x$HAVE_SZLIB" = "xyes" -a "x$HAVE_SZLIB_H" = "xyes"; then
dnl Set LD_LIBRARY_PATH so encoder test can find the library and run.
dnl Also add LL_PATH substitution to Makefiles so they can use the
dnl path as well, for testing examples.
+ if test -z "$LD_LIBRARY_PATH"; then
export LD_LIBRARY_PATH="$szlib_lib"
- AC_SUBST([LL_PATH]) LL_PATH="$szlib_lib"
+ else
+ export LD_LIBRARY_PATH="$szlib_lib:$LD_LIBRARY_PATH"
+ fi
+
+ AC_SUBST([LL_PATH]) LL_PATH="$LD_LIBRARY_PATH"
AC_CACHE_VAL([hdf5_cv_szlib_can_encode],
[AC_TRY_RUN([