summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorQuincey Koziol <koziol@hdfgroup.org>2010-07-20 16:51:49 (GMT)
committerQuincey Koziol <koziol@hdfgroup.org>2010-07-20 16:51:49 (GMT)
commitde3a870bcd4953a3654b3e9dc92edab86fe858cd (patch)
tree8bf2fc6e0814f67b1388c23136aaff9e4a7cba96 /configure.in
parent98754fa9d12090f5e048fdb05cc5e9ce9111676f (diff)
downloadhdf5-de3a870bcd4953a3654b3e9dc92edab86fe858cd.zip
hdf5-de3a870bcd4953a3654b3e9dc92edab86fe858cd.tar.gz
hdf5-de3a870bcd4953a3654b3e9dc92edab86fe858cd.tar.bz2
[svn-r19110] Description:
Bring r19049:19109 from trunk to revise_chunks branch Tested on: FreeBSD/32 6.3 (duty) in debug mode FreeBSD/64 6.3 (liberty) w/C++ & FORTRAN, in debug mode Linux/32 2.6 (jam) w/PGI compilers, w/default API=1.8.x, w/C++ & FORTRAN, w/threadsafe, in debug mode Linux/64-amd64 2.6 (amani) w/Intel compilers, w/default API=1.6.x, w/C++ & FORTRAN, in production mode Solaris/32 2.10 (linew) w/deprecated symbols disabled, w/C++ & FORTRAN, w/szip filter, w/threadsafe, in production mode Linux/PPC 2.6 (heiwa) w/C++ & FORTRAN, w/threadsafe, in debug mode Linux/64-ia64 2.6 (cobalt) w/Intel compilers, w/C++ & FORTRAN, in production mode Linux/64-amd64 2.6 (abe) w/parallel, w/FORTRAN, in debug mode Mac OS X/32 10.6.4 (amazon) in debug mode Mac OS X/32 10.6.4 (amazon) w/C++ & FORTRAN, w/threadsafe, in production mode Mac OS X/32 10.6.4 (amazon) w/parallel, in debug mode
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in106
1 files changed, 48 insertions, 58 deletions
diff --git a/configure.in b/configure.in
index 7728fc3..4add00a 100644
--- a/configure.in
+++ b/configure.in
@@ -26,7 +26,7 @@ dnl
dnl NOTE: Don't forget to change the version number here when we do a
dnl release!!!
dnl
-AC_INIT([HDF5], [1.9.73-FA_a4], [help@hdfgroup.org])
+AC_INIT([HDF5], [1.9.75-FA_a4], [help@hdfgroup.org])
AC_CONFIG_SRCDIR([src/H5.c])
AM_CONFIG_HEADER([src/H5config.h])
@@ -741,65 +741,11 @@ case "$CC_BASENAME" in
fi
;;
- hcc)
- dnl The LAM compiler. Use mpirun_lam or mpirun from the same directory
- dnl if it exists.
- PARALLEL=hcc
- AC_MSG_CHECKING([for mpirun_lam or mpirun])
-
- dnl Find the path where hcc is located
- cmd="`echo $CC | cut -f1 -d' '`"
- if (echo $cmd | grep / >/dev/null); then
- path="`echo $cmd | sed 's/\(.*\)\/.*$/\1/'`"
- else
- for path in `echo $PATH | ${TR} ":" " "`; do
- if test -x $path/$cmd; then
- break
- fi
- done
- fi
-
- dnl Is there an mpirun_lam or mpirun at that path?
- if test -x $path/mpirun_lam -o -x $path/mpirun; then
- if test -x $path/mpirun_lam; then
- cmd=mpirun_lam
- else
- cmd=mpirun
- fi
- AC_MSG_RESULT([$path/$cmd])
- RUNSERIAL="${RUNSERIAL:-none}"
- if test -z "$RUNPARALLEL"; then
- RUNPARALLEL="$path/$cmd -np \$\${NPROCS:=3}"
- fi
- else
- AC_MSG_RESULT([none])
- fi
- ;;
-
mpcc|mpcc_r)
dnl The IBM compiler
PARALLEL="$CC_BASENAME"
;;
- cmpicc)
- dnl The ChaMPIon compiler on NCSA tungsten. The cmpirun command on tungsten
- dnl isn't in the same path as cmpicc.
- PARALLEL=cmpicc
- AC_MSG_CHECKING([for cmpirun])
-
- dnl Is there an cmpirun?
- if test -x cmpirun; then
- AC_MSG_RESULT([cmpirun])
- RUNSERIAL="${RUNSERIAL:-none}"
-
- if test -z "$RUNPARALLEL"; then
- RUNPARALLEL="cmpirun -np \$\${NPROCS:=3}"
- fi
- else
- AC_MSG_RESULT([none])
- fi
- ;;
-
*)
dnl Probably not a parallel compiler, but if `--enable-parallel'
dnl is defined below then we're still building a parallel hdf5.
@@ -3799,8 +3745,46 @@ else
fi
done
fi
-if test -n "$cc_vendor" && test -n "$cc_version"; then
- CC_VERSION="$CC_VERSION ($cc_vendor-$cc_version)"
+if test -n "$cc_version_info"; then
+ CC_VERSION="$CC_VERSION ( $cc_version_info)"
+fi
+
+AC_SUBST([FC_VERSION])
+dnl Strip anything that looks like a flag off of $CC
+FC_NOFLAGS=`echo $FC | sed 's/ -.*//'`
+
+if `echo $FC_NOFLAGS | grep ^/ >/dev/null 2>&1`; then
+ FC_VERSION="$FC"
+else
+ FC_VERSION="$FC";
+ for x in `echo $PATH | sed -e 's/:/ /g'`; do
+ if test -x $x/$FC_NOFLAGS; then
+ FC_VERSION="$x/$FC"
+ break
+ fi
+ done
+fi
+if test -n "$fc_version_info"; then
+ FC_VERSION="$FC_VERSION ( $fc_version_info)"
+fi
+
+AC_SUBST([CXX_VERSION])
+dnl Strip anything that looks like a flag off of $CC
+CXX_NOFLAGS=`echo $CXX | sed 's/ -.*//'`
+
+if `echo $CXX_NOFLAGS | grep ^/ >/dev/null 2>&1`; then
+ CXX_VERSION="$CXX"
+else
+ CXX_VERSION="$FC";
+ for x in `echo $PATH | sed -e 's/:/ /g'`; do
+ if test -x $x/$CXX_NOFLAGS; then
+ CXX_VERSION="$x/$CXX"
+ break
+ fi
+ done
+fi
+if test -n "$cxx_version_info"; then
+ CXX_VERSION="$CXX_VERSION ( $cxx_version_info)"
fi
dnl ----------------------------------------------------------------------
@@ -4158,6 +4142,7 @@ AC_CONFIG_FILES([src/libhdf5.settings
tools/h5stat/testh5stat.sh
tools/h5stat/Makefile
examples/Makefile
+ examples/run-c-ex.sh
examples/testh5cc.sh
c++/Makefile
c++/src/Makefile
@@ -4165,6 +4150,7 @@ AC_CONFIG_FILES([src/libhdf5.settings
c++/test/Makefile
c++/test/H5srcdir_str.h
c++/examples/Makefile
+ c++/examples/run-c++-ex.sh
c++/examples/testh5c++.sh
fortran/Makefile
fortran/src/h5fc
@@ -4172,6 +4158,7 @@ AC_CONFIG_FILES([src/libhdf5.settings
fortran/test/Makefile
fortran/testpar/Makefile
fortran/examples/Makefile
+ fortran/examples/run-fortran-ex.sh
fortran/examples/testh5fc.sh
hl/Makefile
hl/src/Makefile
@@ -4180,14 +4167,17 @@ AC_CONFIG_FILES([src/libhdf5.settings
hl/tools/Makefile
hl/tools/gif2h5/Makefile
hl/examples/Makefile
+ hl/examples/run-hlc-ex.sh
hl/c++/Makefile
hl/c++/src/Makefile
hl/c++/test/Makefile
hl/c++/examples/Makefile
+ hl/c++/examples/run-hlc++-ex.sh
hl/fortran/Makefile
hl/fortran/src/Makefile
hl/fortran/test/Makefile
- hl/fortran/examples/Makefile])
+ hl/fortran/examples/Makefile
+ hl/fortran/examples/run-hlfortran-ex.sh])
AC_OUTPUT
no_create=$saved_no_create