summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorBill Wendling <wendling@ncsa.uiuc.edu>2003-10-22 21:14:17 (GMT)
committerBill Wendling <wendling@ncsa.uiuc.edu>2003-10-22 21:14:17 (GMT)
commit2d730db56ba793281a22ab5a26687f96791b6811 (patch)
tree9dd4b9af88ba0ab75ffb091c50e71a202cf8841b /configure.in
parent68fed88177a131ec9bb3a7b2a7117f6c4bcf96e2 (diff)
downloadhdf5-2d730db56ba793281a22ab5a26687f96791b6811.zip
hdf5-2d730db56ba793281a22ab5a26687f96791b6811.tar.gz
hdf5-2d730db56ba793281a22ab5a26687f96791b6811.tar.bz2
[svn-r7698] Purpose:
Feature Add Description: Readded the FPHDF5 configuration option. Platforms tested: Linux (small and configure-specific) Misc. update:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in21
1 files changed, 10 insertions, 11 deletions
diff --git a/configure.in b/configure.in
index 9bf86a6..5e466b4 100644
--- a/configure.in
+++ b/configure.in
@@ -2294,21 +2294,22 @@ dnl ----------------------------------------------------------------------
AC_DEFINE([HAVE_MPE], [1], [Define if we have MPE support])
fi
-dnl ----------------------------------------------------------------------
-dnl Check if they would like the "Flexible parallel" functions compiled in
-dnl
+ dnl ----------------------------------------------------------------------
+ dnl Check if they would like the "Flexible parallel" interface enabled
+ dnl
AC_MSG_CHECKING([if Flexible Parallel HDF5 interface enabled])
AC_ARG_ENABLE([fphdf5],
[AC_HELP_STRING([--enable-fphdf5],
[Enable the Flexible Parallel HDF5
- interface])],
- [FPHDF5=$enableval])
+ interface [default=no]])],
+ [FPHDF5=$enableval],
+ [FPHDF5="no"])
if test "X$FPHDF5" = "Xyes"; then
AC_DEFINE(HAVE_FPHDF5, 1,
[Define if we want flexible parallel HDF5 support])
- AC_MSG_RESULT(yes)
+ AC_MSG_RESULT([yes])
else
- AC_MSG_RESULT(no)
+ AC_MSG_RESULT([no])
fi
dnl ----------------------------------------------------------------------
@@ -2794,10 +2795,8 @@ PRINT "Features:"
PRINT_N " dmalloc"
IF_YES_NO "$HAVE_DMALLOC"
-dnl
-dnl PRINT_N " Flexible Parallel HDF"
-dnl IF_YES_NO "$FPHDF5"
-dnl
+PRINT_N " Flexible Parallel HDF"
+IF_YES_NO "$FPHDF5"
PRINT_N " Function Stack Tracing"
IF_ENABLED_DISABLED "$FUNCSTACK"