summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorBill Wendling <wendling@ncsa.uiuc.edu>2002-02-13 20:53:07 (GMT)
committerBill Wendling <wendling@ncsa.uiuc.edu>2002-02-13 20:53:07 (GMT)
commit530133a9f4ae32fe26acf981209f018f9492c35a (patch)
tree6c4f32fdbf0774965c3c70625611cabf9778432f /configure.in
parent807207079a9bcf72d3d82d9ca0676f67d721507a (diff)
downloadhdf5-530133a9f4ae32fe26acf981209f018f9492c35a.zip
hdf5-530133a9f4ae32fe26acf981209f018f9492c35a.tar.gz
hdf5-530133a9f4ae32fe26acf981209f018f9492c35a.tar.bz2
[svn-r4956]
Purpose: Bug Fix Description: On some systems, doing the shell command: if test -z $DEBUG_PKG; then doesn't work if $DEBUG_PKG is null.. Solution: Changed to "if test "X$DEBUG_PKG" = "X"; then" which will do the same thing but without the error... Platforms tested: Linux
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in82
1 files changed, 80 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 2e8451d..f719e08 100644
--- a/configure.in
+++ b/configure.in
@@ -774,6 +774,69 @@ case $withval in
;;
esac
+dnl ----------------------------------------------------------------------
+dnl Pablo Configuration
+dnl
+AC_SUBST(PABLO) PABLO=""
+AC_SUBST(HAVE_PABLO) HAVE_PABLO="no"
+AC_ARG_WITH(pablo,
+ [ --with-pablo[=DIR] Use the Pablo library [default=no]],,
+ withval=no)
+
+case "$withval" in
+ yes)
+ failed="no"
+ AC_CHECK_LIB(PabloTraceExt, initIOTrace,, failed="yes")
+
+ if test "$failed" != "yes"; then
+ HAVE_PABLO="yes"
+ PABLO="pablo"
+ fi
+ ;;
+ no)
+ AC_MSG_CHECKING(for Pablo)
+ AC_MSG_RESULT(suppressed)
+ ;;
+ *)
+ case "$withval" in
+ *,*)
+ pablo_inc="`echo $withval | cut -f1 -d,`"
+ pablo_lib="`echo $withval | cut -f2 -d, -s`"
+ ;;
+ *)
+ if test -n "$withval"; then
+ pablo_inc="$withval/include"
+ pablo_lib="$withval/lib"
+ fi
+ ;;
+ esac
+
+ saved_CPPFLAGS="$CPPFLAGS"
+ saved_LDFLAGS="$LDFLAGS"
+ if test -n "$pablo_inc"; then
+ CPPFLAGS="$CPPFLAGS -I$pablo_inc"
+ fi
+
+ if test -n "$pablo_lib"; then
+ LDFLAGS="$LDFLAGS -L$pablo_lib"
+ fi
+
+ failed="no"
+ AC_CHECK_HEADERS(IOTrace.h,
+ AC_CHECK_LIB(PabloTraceExt, initIOTrace,, failed="yes"),
+ failed="yes")
+
+ if test "$failed" = "yes"; then
+ dnl Reset flags if failed
+ CPPFLAGS="$saved_CPPFLAGS"
+ LDFLAGS="$saved_LDFLAGS"
+ else
+ HAVE_PABLO="yes"
+ PABLO="pablo"
+ fi
+ ;;
+esac
+
dnl Is SSL library present? It is needed by GLOBUS-GASS and Grid Storage
dnl driver. SSL must be tested before them.
AC_SUBST(SSL) SSL=yes
@@ -1759,6 +1822,18 @@ if test -n "$TESTPARALLEL"; then
PARALLEL_MAKE="$TESTPARALLEL/Makefile"
fi
+PABLO_MAKE=""
+
+AC_SUBST(PARALLEL_PABLO) PARALLEL_PABLO=""
+
+if test -n "$HAVE_PABLO"; then
+ PABLO_MAKE="pablo/Makefile"
+
+ if test -n "$TESTPARALLEL"; then
+ PARALLEL_PABLO="yes"
+ fi
+fi
+
EXTRA_H4_MAKEFILES=""
if test -n "$H4TOH5"; then
@@ -1779,7 +1854,7 @@ AC_OUTPUT(src/libhdf5.settings
config/conclude
Makefile
src/Makefile
- pablo/Makefile
+ $PABLO_MAKE
test/Makefile
$PARALLEL_MAKE
perform/Makefile
@@ -1883,7 +1958,7 @@ PRINT_N " Debug Mode"
if test "X$DEBUG_PKG" = "X$all_packages"; then
PRINT "All"
-elif test -z $DEBUG_PKG; then
+elif test "X$DEBUG_PKG" = "X"; then
PRINT "None"
else
PRINT $DEBUG_PKG
@@ -1931,6 +2006,9 @@ esac
PRINT_N " Linux Large File Support (LFS)"
IF_ENABLED_DISABLED "$LINUX_LFS"
+PRINT_N " Pablo"
+IF_YES_NO "$HAVE_PABLO"
+
PRINT_N " Parallel HDF5"
if test "$PARALLEL" != "no"; then
PRINT "Yes"