summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorQuincey Koziol <koziol@hdfgroup.org>2003-12-29 19:34:11 (GMT)
committerQuincey Koziol <koziol@hdfgroup.org>2003-12-29 19:34:11 (GMT)
commit5db6c61f18198ac4477a6ba99d405ff82cf467a7 (patch)
tree4cf9ef4d947830f28f12d110148c3bfea6ff49e9 /configure.in
parentb6fd9f9d760dbe4e6ab530b12e0672088570224a (diff)
downloadhdf5-5db6c61f18198ac4477a6ba99d405ff82cf467a7.zip
hdf5-5db6c61f18198ac4477a6ba99d405ff82cf467a7.tar.gz
hdf5-5db6c61f18198ac4477a6ba99d405ff82cf467a7.tar.bz2
[svn-r7993] Purpose:
Code cleanup, bug fixes Description: Wrap up rest of changes necessary for fixing the "short" MPI-I/O read problem that Robb reported. Platforms tested: FreeBSD 4.9 (sleipnir) too minor to require h5committest
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in29
1 files changed, 0 insertions, 29 deletions
diff --git a/configure.in b/configure.in
index 17669ee..c2e9ef8 100644
--- a/configure.in
+++ b/configure.in
@@ -2194,35 +2194,6 @@ if test -n "$PARALLEL"; then
)
fi
-dnl ----------------------------------------------------------------------
-dnl Block the MPI_Get_count code since it does not work
-dnl dnl Check whether MPI_Get_count actually works correctly on this
-dnl dnl platform.
-dnl AC_MSG_CHECKING(whether a MPI_Get_count works correctly)
-dnl AC_TRY_RUN([
-dnl #include <mpi.h>
-dnl
-dnl int main(int argc, char **argv)
-dnl {
-dnl MPI_Status mpi_stat;
-dnl int bytes_read = 0, ret;
-dnl
-dnl MPI_Init(&argc, &argv);
-dnl memset(&mpi_stat, 0, sizeof(MPI_Status)); /* zero out status */
-dnl ret = MPI_Get_count(&mpi_stat, MPI_BYTE, &bytes_read);
-dnl MPI_Finalize();
-dnl
-dnl /* this returns TRUE if bytes_read is 0...the shell thinks that the
-dnl * program fails, but we want it to fail of course so switch the
-dnl * "true"/"false" parts of the TRY_RUN macro */
-dnl return bytes_read == 0;
-dnl }
-dnl ],
-dnl AC_MSG_RESULT(no),
-dnl AC_MSG_RESULT(yes)
-dnl CPPFLAGS="$CPPFLAGS -DMPI_GET_COUNT_WORKS",AC_MSG_RESULT(no))
-dnl ----------------------------------------------------------------------
-
dnl --------------------------------------------------------------------
dnl Do we want MPE instrumentation feature on?
dnl