summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorAlbert Cheng <acheng@hdfgroup.org>2000-03-30 21:33:24 (GMT)
committerAlbert Cheng <acheng@hdfgroup.org>2000-03-30 21:33:24 (GMT)
commit69967557a87289cc6ac7fd3698438979d57a05cf (patch)
tree07f113806515e38769013d77707ce6a3523a96d5 /configure.in
parentdcec973faab073cd149fbebfbc61bc775505f696 (diff)
downloadhdf5-69967557a87289cc6ac7fd3698438979d57a05cf.zip
hdf5-69967557a87289cc6ac7fd3698438979d57a05cf.tar.gz
hdf5-69967557a87289cc6ac7fd3698438979d57a05cf.tar.bz2
[svn-r2061] Changed the parsing of --enable-debug option to case statement
style instead of it-then-else. It makes it easier to understand and easier to change the defaults of it.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in15
1 files changed, 10 insertions, 5 deletions
diff --git a/configure.in b/configure.in
index 0e39ed6..d598344 100644
--- a/configure.in
+++ b/configure.in
@@ -835,21 +835,26 @@ AC_ARG_ENABLE(debug,
AC_SUBST(DEBUG_PKG)
all_packages="ac,b,d,e,f,g,hg,hl,i,mf,mm,o,p,s,t,v,z"
-if test X = "X$DEBUG_PKG" -o Xyes = "X$DEBUG_PKG"; then
+case X-$DEBUG_PKG in
+ X-|X-yes)
DEBUG_PKG="d,e,f,g,hg,i,mm,o,p,s,t,v,z"
CPPFLAGS="$CPPFLAGS -UNDEBUG"
AC_MSG_RESULT(default ($DEBUG_PKG))
-elif test Xall = "X$DEBUG_PKG"; then
+ ;;
+ X-all)
DEBUG_PKG=$all_packages
CPPFLAGS="$CPPFLAGS -UNDEBUG"
AC_MSG_RESULT(all ($DEBUG_PKG))
-elif test Xno = "X$DEBUG_PKG" -o Xnone = "X$DEBUG_PKG"; then
+ ;;
+ X-no|X-none)
AC_MSG_RESULT(none)
DEBUG_PKG=
CPPFLAGS="$CPPFLAGS -DNDEBUG"
-else
+ ;;
+ *)
AC_MSG_RESULT($DEBUG_PKG)
-fi
+ ;;
+esac
if test "X" != "X$DEBUG_PKG"; then
for pkg in `echo $DEBUG_PKG | tr 'a-z,' 'A-Z '`; do