summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorBill Wendling <wendling@ncsa.uiuc.edu>2001-02-12 22:52:00 (GMT)
committerBill Wendling <wendling@ncsa.uiuc.edu>2001-02-12 22:52:00 (GMT)
commit7c0fb27132f560754343d96b5882682482646b65 (patch)
treee14677277b85e0bc68ab591ad42ef66fe460aedd /configure.in
parente361fef08b1d0a9aecb7c1433a401fbea805154e (diff)
downloadhdf5-7c0fb27132f560754343d96b5882682482646b65.zip
hdf5-7c0fb27132f560754343d96b5882682482646b65.tar.gz
hdf5-7c0fb27132f560754343d96b5882682482646b65.tar.bz2
[svn-r3403] Purpose:
Fix Description: On machines which use the bin/install-sh script, it wasn't picking up the install-sh script unless it was one directory depth away from it (ie, it thought that it was in ../bin/install-sh, which isn't good if, like with the documentation, it's in a deeper directory). Solution: Hacked it up so that, if it does use the broken relative-path schema, then it will change it to use the $(top_srcdir) macro instead. Platforms tested: Linux
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index bb40057..31e3a84 100644
--- a/configure.in
+++ b/configure.in
@@ -235,6 +235,14 @@ AC_PROG_INSTALL
AC_LIBTOOL_DLOPEN
AM_PROG_LIBTOOL
+dnl Fix up the INSTALL macro if it's a relative path. We want the
+dnl full-path to the binary instead.
+case "$INSTALL" in
+ ../bin/install-sh)
+ INSTALL='\${top_srcdir}'/bin/install-sh
+ ;;
+esac
+
AC_MSG_CHECKING(make)
AC_SUBST_FILE(DEPEND)
if test "`${MAKE-make} --version -f /dev/null 2>/dev/null |\