summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorQuincey Koziol <koziol@hdfgroup.org>2001-01-04 01:30:43 (GMT)
committerQuincey Koziol <koziol@hdfgroup.org>2001-01-04 01:30:43 (GMT)
commit85c19fc0bac344a477066c8239c3a8f935abd75c (patch)
tree419991436669a3e83dffc3810af97bcd65d9b674 /configure.in
parentd3301180f53714fb1bda0856ccfe5db15d0c0260 (diff)
downloadhdf5-85c19fc0bac344a477066c8239c3a8f935abd75c.zip
hdf5-85c19fc0bac344a477066c8239c3a8f935abd75c.tar.gz
hdf5-85c19fc0bac344a477066c8239c3a8f935abd75c.tar.bz2
[svn-r3235] Purpose:
Improve compiler warnings Description: Added several more warning flags to the gcc compiler flags.. Platforms tested: FreeBSD 4.2 (hawkwind)
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index f3f3f15..cc85103 100644
--- a/configure.in
+++ b/configure.in
@@ -336,7 +336,7 @@ dnl ----------------------------------------------------------------------
dnl Turn on warning flags for gcc.
dnl
if test "X$GCC" = "Xyes"; then
- CFLAGS="$CFLAGS -Wall -W -Wshadow -Wpointer-arith -Wbad-function-cast -Wcast-qual -Wcast-align -Wwrite-strings -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations -Wnested-externs -Winline"
+ CFLAGS="$CFLAGS -ansi -pedantic -Wchar-subscripts -Wconversion -Wredundant-decls -Wall -W -Wshadow -Wpointer-arith -Wbad-function-cast -Wcast-qual -Wcast-align -Wwrite-strings -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations -Wnested-externs -Winline"
fi
dnl ----------------------------------------------------------------------