summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorBill Wendling <wendling@ncsa.uiuc.edu>2003-10-13 20:56:27 (GMT)
committerBill Wendling <wendling@ncsa.uiuc.edu>2003-10-13 20:56:27 (GMT)
commit8d5bcd338d2019fa37b60d267be49da9d324628d (patch)
treea5b2c6d69a2e5636ca49592167233c1e83147338 /configure.in
parent324cd9d1e28824d4f686809b21e3d41deb1bf515 (diff)
downloadhdf5-8d5bcd338d2019fa37b60d267be49da9d324628d.zip
hdf5-8d5bcd338d2019fa37b60d267be49da9d324628d.tar.gz
hdf5-8d5bcd338d2019fa37b60d267be49da9d324628d.tar.bz2
[svn-r7618] Purpose:
Add check Description: Added a check to make sure that the "tr" program actually works. Platforms tested: Linux (small fix and only to configure) Misc. update:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in13
1 files changed, 13 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 210ef35..a628368 100644
--- a/configure.in
+++ b/configure.in
@@ -67,6 +67,19 @@ set >&AS_MESSAGE_LOG_FD
AC_MSG_RESULT([done])
dnl ----------------------------------------------------------------------
+dnl Some platforms have broken ``tr'' programs. Check that it actually
+dnl does what it's supposed to do. Catch this early since configure
+dnl relies upon tr heavily and there's no use continuing if it's broken.
+dnl
+AC_MSG_CHECKING([if tr works])
+TRTEST=`echo "Test" | tr 'a-z,' 'A-Z '`
+if test $TRTEST != "TEST"; then
+ AC_MSG_ERROR([tr program doesn't work])
+else
+ AC_MSG_RESULT([yes])
+fi
+
+dnl ----------------------------------------------------------------------
dnl Check that the cache file was build on the same host as what we're
dnl running on now.
dnl