summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorBill Wendling <wendling@ncsa.uiuc.edu>2000-11-14 17:34:38 (GMT)
committerBill Wendling <wendling@ncsa.uiuc.edu>2000-11-14 17:34:38 (GMT)
commita858f98bf62e7737c02c26308f9398c26d69860e (patch)
tree71e13b8ecccd6dc1b7f6b8d9f6dd007dc1fbb186 /configure.in
parentf71306c9d8f43059c267090cbbfbfd6f18e3e619 (diff)
downloadhdf5-a858f98bf62e7737c02c26308f9398c26d69860e.zip
hdf5-a858f98bf62e7737c02c26308f9398c26d69860e.tar.gz
hdf5-a858f98bf62e7737c02c26308f9398c26d69860e.tar.bz2
[svn-r2894] Purpose:
Command-line name change Description: Changed --with-stream-vfd to --enable-strea-vfd to be more consistent with what people expect from the --with-FOO and --enable-FOO arguments.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in111
1 files changed, 54 insertions, 57 deletions
diff --git a/configure.in b/configure.in
index 56ff9ed..bbca21d 100644
--- a/configure.in
+++ b/configure.in
@@ -489,21 +489,6 @@ case $HSIZET in
;;
esac
-dnl ----------------------------------------------------------------------
-dnl Check if they would like the HDF5 v1.2 compatibility functions compiled in
-dnl
-AC_MSG_CHECKING(whether HDF5 v1.2 compatibility functions enabled)
-AC_ARG_ENABLE(hdf5v1_2,
- [ --enable-hdf5v1_2 Compile the HDF5 v1.2 compatibility interface [default=no]],
- HDF5_V1_2_COMPAT=$enableval)
-
-if test "X$HDF5_V1_2_COMPAT" = "Xyes"; then
- AC_MSG_RESULT(yes)
- AC_DEFINE(WANT_H5_V1_2_COMPAT)
-else
- AC_MSG_RESULT(no)
-fi
-
dnl Checkpoint the cache
AC_CACHE_SAVE
@@ -802,46 +787,6 @@ if test -n "$GRIDSTORAGE"; then
fi
dnl ----------------------------------------------------------------------
-dnl Should the Stream Virtual File Driver be compiled in ?
-dnl
-AC_MSG_CHECKING(for Stream Virtual File Driver support)
-AC_ARG_WITH(stream-vfd,
- [ --with-stream-vfd Build the Stream Virtual File Driver [default=no]],
- ,withval=no)
-
-case "$withval" in
- yes)
- AC_MSG_RESULT(yes)
- AC_CHECK_HEADERS(netinet/tcp.h)
- AC_DEFINE(HAVE_STREAM)
-
- dnl Check if 'socklen_t' available
- AC_MSG_CHECKING([if socklen_t is defined])
- AC_TRY_COMPILE(
- [
-#include <stdio.h>
-#include <stdlib.h>
-#ifdef HAVE_UNISTD_H
-#include <unistd.h>
-#endif
-#ifdef HAVE_SYS_TYPES_H
-#include <sys/types.h>
-#endif
-#ifdef HAVE_SYS_SOCKET_H
-#include <sys/socket.h>
-#endif
- ],
- [socklen_t foo; return 0;],
- AC_DEFINE(HAVE_SOCKLEN_T) AC_MSG_RESULT(yes),
- AC_MSG_RESULT(no)
- )
- ;;
- *)
- AC_MSG_RESULT(not configured)
- ;;
-esac
-
-dnl ----------------------------------------------------------------------
dnl Is LLNL's PDB present? If so then we'll compile the PDB-to-HDF5
dnl translator.
dnl
@@ -935,6 +880,58 @@ if test "X$THREADSAFE" = "Xyes"; then
fi
dnl ----------------------------------------------------------------------
+dnl Check if they would like the HDF5 v1.2 compatibility functions
+dnl compiled in
+dnl
+AC_MSG_CHECKING(whether HDF5 v1.2 compatibility functions enabled)
+AC_ARG_ENABLE(hdf5v1_2,
+ [ --enable-hdf5v1_2 Compile the HDF5 v1.2 compatibility interface [default=no]],
+ HDF5_V1_2_COMPAT=$enableval)
+
+if test "X$HDF5_V1_2_COMPAT" = "Xyes"; then
+ AC_MSG_RESULT(yes)
+ AC_DEFINE(WANT_H5_V1_2_COMPAT)
+else
+ AC_MSG_RESULT(no)
+fi
+
+dnl ----------------------------------------------------------------------
+dnl Should the Stream Virtual File Driver be compiled in ?
+dnl
+AC_MSG_CHECKING(for Stream Virtual File Driver support)
+AC_ARG_ENABLE(stream-vfd,
+ [ --enable-stream-vfd Build the Stream Virtual File Driver. [default=no]],
+ STREAM_VFD=$enableval)
+
+if test "X$STREAM_VFD" = "Xyes"; then
+ AC_MSG_RESULT(yes)
+ AC_CHECK_HEADERS(netinet/tcp.h)
+ AC_DEFINE(HAVE_STREAM)
+
+ dnl Check if 'socklen_t' available
+ AC_MSG_CHECKING([if socklen_t is defined])
+ AC_TRY_COMPILE([
+#include <stdio.h>
+#include <stdlib.h>
+#ifdef HAVE_UNISTD_H
+#include <unistd.h>
+#endif
+#ifdef HAVE_SYS_TYPES_H
+#include <sys/types.h>
+#endif
+#ifdef HAVE_SYS_SOCKET_H
+#include <sys/socket.h>
+#endif
+ ],
+ [socklen_t foo; return 0;],
+ AC_DEFINE(HAVE_SOCKLEN_T) AC_MSG_RESULT(yes),
+ AC_MSG_RESULT(no)
+ )
+else
+ AC_MSG_RESULT(not configured)
+fi
+
+dnl ----------------------------------------------------------------------
dnl How does one figure out the local time zone? Anyone know of a
dnl Posix way to do this?
dnl
@@ -1085,9 +1082,9 @@ dnl Turn on debugging by setting compiler flags
dnl
AC_MSG_CHECKING(for debug flags)
AC_ARG_ENABLE(debug,
- [ --enable-debug[=all] Turn on debugging in all packages. One may also
+ [ --enable-debug[=all] Turn on debugging in all packages. One may also
specify a comma-separated list of package names
- without the leading H5 or the word no. The default
+ without the leading H5 or the word no. The default
is most packages.],
DEBUG_PKG=$enableval)