summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorThomas Radke <tradke@aei.mpg.de>2000-09-15 11:14:40 (GMT)
committerThomas Radke <tradke@aei.mpg.de>2000-09-15 11:14:40 (GMT)
commita8932fbddcb0a0920aa5262b7a9390662ebae623 (patch)
tree7e1146b2c07af4d2ab8ca4fbe99e6cc835fd7624 /configure.in
parent3a590c6e5c1740d7634d0801f49aa56085db1f93 (diff)
downloadhdf5-a8932fbddcb0a0920aa5262b7a9390662ebae623.zip
hdf5-a8932fbddcb0a0920aa5262b7a9390662ebae623.tar.gz
hdf5-a8932fbddcb0a0920aa5262b7a9390662ebae623.tar.bz2
[svn-r2553] Purpose:
Added new option --with-Stream-VFD. Description: The configure option --with-Stream-VFD[={yes}|{no}] is used to configure HDF5 to build the Stream Virtual File Driver. The default is not to build it. Platforms: all platforms
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in18
1 files changed, 18 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index c5fcf6f..37f7c79 100644
--- a/configure.in
+++ b/configure.in
@@ -754,6 +754,24 @@ if test -n "$GRIDSTORAGE"; then
fi
dnl ----------------------------------------------------------------------
+dnl Should the Stream Virtual File Driver be compiled in ?
+dnl
+AC_MSG_CHECKING(for Stream Virtual File Driver support)
+AC_ARG_WITH(Stream-VFD,
+ [ --with-Stream-VFD Build the Stream Virtual File Driver [default=no]],
+ ,withval=no)
+
+case $withval in
+ yes)
+ AC_MSG_RESULT(yes)
+ AC_DEFINE(HAVE_STREAM)
+ ;;
+ *)
+ AC_MSG_RESULT(not configured)
+ ;;
+esac
+
+dnl ----------------------------------------------------------------------
dnl Is LLNL's PDB present? If so then we'll compile the PDB-to-HDF5
dnl translator.
AC_SUBST(PDB2HDF)