summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorThomas Radke <tradke@aei.mpg.de>2000-11-08 22:33:24 (GMT)
committerThomas Radke <tradke@aei.mpg.de>2000-11-08 22:33:24 (GMT)
commitae1a3c13002aeaf84bae8bdebc1215a2a67d34c7 (patch)
tree3d08e62ae7f1499836f696b5b4231c541db86d61 /configure.in
parent50333fe5150928e755a33933810e46c1bb1966da (diff)
downloadhdf5-ae1a3c13002aeaf84bae8bdebc1215a2a67d34c7.zip
hdf5-ae1a3c13002aeaf84bae8bdebc1215a2a67d34c7.tar.gz
hdf5-ae1a3c13002aeaf84bae8bdebc1215a2a67d34c7.tar.bz2
[svn-r2830]
Purpose: Bugfix Description: Rename the [H5_]HAVE_STRUCT_SOCKLEN_T into [H5_]HAVE_SOCKLEN_T. Solution: As pointed out by Bill the socklen_t type isn't a structure if is it defined by the system headers. So we should better take out the _STRUCT_ from the defines. Platforms tested:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index d044713..dc50acd 100644
--- a/configure.in
+++ b/configure.in
@@ -800,8 +800,8 @@ case "$withval" in
AC_CHECK_HEADERS(netinet/tcp.h)
AC_DEFINE(HAVE_STREAM)
- dnl Check if we have struct socklen_t available
- AC_MSG_CHECKING([if struct socklen_t is defined])
+ dnl Check if 'socklen_t' available
+ AC_MSG_CHECKING([if socklen_t is defined])
AC_TRY_COMPILE(
[
#include <stdio.h>
@@ -817,7 +817,7 @@ case "$withval" in
#endif
],
[socklen_t foo; return 0;],
- AC_DEFINE(HAVE_STRUCT_SOCKLEN_T) AC_MSG_RESULT(yes),
+ AC_DEFINE(HAVE_SOCKLEN_T) AC_MSG_RESULT(yes),
AC_MSG_RESULT(no)
)
;;