summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorRobb Matzke <matzke@llnl.gov>1999-03-01 19:44:32 (GMT)
committerRobb Matzke <matzke@llnl.gov>1999-03-01 19:44:32 (GMT)
commitb3ddd2cc5428b052ca26b36634b64be21032a330 (patch)
treed29670f49933b5259ca1cfd2a959f336ccb4bf5d /configure.in
parent90d07791d37f965638b96eb2b4ad48b60708a9dc (diff)
downloadhdf5-b3ddd2cc5428b052ca26b36634b64be21032a330.zip
hdf5-b3ddd2cc5428b052ca26b36634b64be21032a330.tar.gz
hdf5-b3ddd2cc5428b052ca26b36634b64be21032a330.tar.bz2
[svn-r1110] Changes since 19990226
---------------------- ./INSTALL Added instructions for using other compilers on Irix platforms. ./configure.in ./configure [REGENERATED] ./src/H5config.h.in [REGENERATED] ./src/H5private.h The presence of <sys/sysinfo.h> and <sys/proc.h> is only checked on DEC/Alpha because there are too many problems including these headers on other systems. ./config/irix6.x ./config/irix64 Removed `-ansi' and added a comment. Converting an ASCII UTC date and time to a time_t value is not defined by ANSI or Posix but is available if we don't use `-ansi'. This allows the dataset modification time messages to be read properly by H5Gget_objinfo(). ./src/H5Tconv.c Fixed a compiler warning. ./test/dtypes.c ./test/hyperslab.c ./test/istore.c Fixed compiler warnings in printf() statements.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in9
1 files changed, 8 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index e11fb3b..db13084 100644
--- a/configure.in
+++ b/configure.in
@@ -1,3 +1,4 @@
+
dnl Process this file with autoconf to produce configure.
dnl
dnl Copyright (C) 1997 National Center for Supercomputing Applications.
@@ -143,10 +144,16 @@ AC_HEADER_STDC
AC_HEADER_TIME
dnl Unix
AC_CHECK_HEADERS(sys/resource.h sys/time.h unistd.h sys/ioctl.h sys/stat.h)
-AC_CHECK_HEADERS(stddef.h sys/sysinfo.h sys/proc.h sys/param.h)
+AC_CHECK_HEADERS(stddef.h)
dnl Windows
AC_CHECK_HEADERS(io.h winsock.h sys/timeb.h)
+dnl The <sys/sysinfo.h> and <sys/proc.h> are needed on the DEC Alpha
+dnl to turn off UAC fixing. We do *not* attempt to locate these files on
+dnl other systems because there are too many problems with including them.
+if test "$host_vendor-$host_cpu" = "dec-alpha"; then
+ AC_CHECK_HEADERS(sys/sysinfo.h sys/proc.h)
+fi
dnl ----------------------------------------------------------------------
dnl Data types and their sizes.