summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorAlbert Cheng <acheng@hdfgroup.org>2001-03-19 22:31:06 (GMT)
committerAlbert Cheng <acheng@hdfgroup.org>2001-03-19 22:31:06 (GMT)
commitd178c72f9c976e56e1dc44706d33124bdf86a52d (patch)
tree674e1388ffd15a5a8b7bfbb3a142e1619c98d132 /configure.in
parent2aefa8a0a4fda831718ba5e2806f404f873a64f7 (diff)
downloadhdf5-d178c72f9c976e56e1dc44706d33124bdf86a52d.zip
hdf5-d178c72f9c976e56e1dc44706d33124bdf86a52d.tar.gz
hdf5-d178c72f9c976e56e1dc44706d33124bdf86a52d.tar.bz2
[svn-r3663] Purpose:
Improvement Description: Changed the default value of $NPROCS from 2 to 3. This is the value libSAF uses since 3 processes have a much bigger chance catching parallel errors than just 2 processes. Platforms tested: Modi4 (IRIX64) both serial and parallel modes.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index 8ec2693..0193c1e 100644
--- a/configure.in
+++ b/configure.in
@@ -1220,7 +1220,7 @@ case "$CC_BASENAME" in
AC_MSG_RESULT($path/mpirun)
RUNSERIAL="${RUNSERIAL:-none}"
if test -z "$RUNPARALLEL"; then
- RUNPARALLEL="$path/mpirun -np \$\${NPROCS:=2}"
+ RUNPARALLEL="$path/mpirun -np \$\${NPROCS:=3}"
fi
else
AC_MSG_RESULT(none)
@@ -1255,7 +1255,7 @@ case "$CC_BASENAME" in
AC_MSG_RESULT($path/$cmd);
RUNSERIAL="${RUNSERIAL:-none}"
if test -z "$RUNPARALLEL"; then
- RUNPARALLEL="$path/$cmd -np \$\${NPROCS:=2}"
+ RUNPARALLEL="$path/$cmd -np \$\${NPROCS:=3}"
fi
else
AC_MSG_RESULT(none)
@@ -1311,7 +1311,7 @@ case "X-$enable_parallel" in
dnl Set RUNPARALLEL to mpirun if not set yet.
if test "X$PARALLEL" = "Xyes" -a -z "$RUNPARALLEL"; then
- RUNPARALLEL="mpirun -np \$\${NPROCS:=2}"
+ RUNPARALLEL="mpirun -np \$\${NPROCS:=3}"
fi
;;