summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorQuincey Koziol <koziol@hdfgroup.org>2003-09-16 17:33:00 (GMT)
committerQuincey Koziol <koziol@hdfgroup.org>2003-09-16 17:33:00 (GMT)
commitd7bde16f45fac765f45172d88a1a9cd44a1f95fa (patch)
treebe73c954ea0220b752cfbb49597e35954aa47cd9 /configure.in
parentbf1c2f0e8bf9788c2e47a1b1ac963cc321afab0e (diff)
downloadhdf5-d7bde16f45fac765f45172d88a1a9cd44a1f95fa.zip
hdf5-d7bde16f45fac765f45172d88a1a9cd44a1f95fa.tar.gz
hdf5-d7bde16f45fac765f45172d88a1a9cd44a1f95fa.tar.bz2
[svn-r7480] Purpose:
Bug fix Description: The MPI_File_set_size() routine on ASCI Red is not able to extend files so that they are larger than 2GB. Solution: Add an extra macro which controls whether MPI_File_set_size() can handle >2GB offsets or if our "older" way of reading a byte, then writing a byte at the appropriate offset should be used. Platforms tested: FreeBSD 4.9 (sleipnir) h5committest
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in22
1 files changed, 20 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 363a00d..2f83597 100644
--- a/configure.in
+++ b/configure.in
@@ -1683,7 +1683,7 @@ int main(void)
if test ${hdf5_cv_malloc_works} = "yes"; then
AC_DEFINE([MALLOC_WORKS], [1],
- [Define if your system has a working \`malloc' function.])
+ [Define if your system's \`malloc' function returns a valid pointer for 0-byte allocations.])
AC_MSG_RESULT([yes])
else
AC_MSG_RESULT([no])
@@ -2296,8 +2296,26 @@ dnl
else
AC_MSG_RESULT(no)
fi
-fi
+ dnl ----------------------------------------------------------------------
+ dnl Set the flag to indicate that the MPI_File_set_size() function
+ dnl works with files over 2GB, unless it's already set in the cache.
+ dnl (This flag should be set for all machines, except for ASCI Red, where
+ dnl the cache value is set in it's config file)
+ dnl
+ AC_MSG_CHECKING([if MPI_File_set_size works for files over 2GB])
+ AC_CACHE_VAL([hdf5_cv_mpi_file_set_size_big], [hdf5_cv_mpi_file_set_size_big=yes])
+
+ if test ${hdf5_cv_mpi_file_set_size_big} = "yes"; then
+ AC_DEFINE([MPI_FILE_SET_SIZE_BIG], [1],
+ [Define if your system's \`MPI_File_set_size' function works for files over 2GB.])
+ AC_MSG_RESULT([yes])
+ else
+ AC_MSG_RESULT([no])
+ fi
+
+fi
+
dnl ----------------------------------------------------------------------
dnl Turn on internal I/O filters by setting macros in header files
dnl Internal I/O filters are contained entirely within the library and do