summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorQuincey Koziol <koziol@hdfgroup.org>2004-04-28 18:42:25 (GMT)
committerQuincey Koziol <koziol@hdfgroup.org>2004-04-28 18:42:25 (GMT)
commitd992a4a387d543332c8fcc7e3cdebef5bcc47e7d (patch)
tree865d8ea1a9f1685d8fd37e4cf7a8f36da7e7e271 /configure.in
parent480e8d4c9cf0d4b399de7564cc15c4b372e90f51 (diff)
downloadhdf5-d992a4a387d543332c8fcc7e3cdebef5bcc47e7d.zip
hdf5-d992a4a387d543332c8fcc7e3cdebef5bcc47e7d.tar.gz
hdf5-d992a4a387d543332c8fcc7e3cdebef5bcc47e7d.tar.bz2
[svn-r8427] Purpose:
Bug fix (sorta) Description: Add hack to allow the MS Visual Studio 6 compiler to build the library. It cannot cast unsigned long long values to float or double values. So, add another configuration macro to disable this conversion in the library. Just the "hardware" conversion is disabled, so the library will still correctly convert unsigned long long to float and double values, it will just happen more slowly with the "software" conversion routine. Platforms tested: FreeBSD 4.9 (sleipnir) with "Windows" setting faked inappropriate for h5committest
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in18
1 files changed, 18 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index dee22c2..61bf9d7 100644
--- a/configure.in
+++ b/configure.in
@@ -2398,6 +2398,24 @@ else
fi
dnl ----------------------------------------------------------------------
+dnl Set the flag to indicate that the machine can _compile_
+dnl 'unsigned long long' to 'float' and 'double' typecasts.
+dnl (This flag should be set for all machines, except for under Windows when
+dnl compiled with Visual Studio 6, where the macro value is set in the
+dnl src/H5pubconf.h file)
+dnl
+AC_MSG_CHECKING([if compiling unsigned long long to floating-point typecasts work])
+AC_CACHE_VAL([hdf5_cv_ullong_to_fp_cast_works], [hdf5_cv_ullong_to_fp_cast_works=yes])
+
+if test ${hdf5_cv_ullong_to_fp_cast_works} = "yes"; then
+ AC_DEFINE([ULLONG_TO_FP_CAST_WORKS], [1],
+ [Define if your system can compile unsigned long long to floating-point casts.])
+ AC_MSG_RESULT([yes])
+else
+ AC_MSG_RESULT([no])
+fi
+
+dnl ----------------------------------------------------------------------
dnl Set some variables for general configuration information to be saved
dnl and installed with the libraries.
dnl