summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorBill Wendling <wendling@ncsa.uiuc.edu>2000-11-03 20:29:11 (GMT)
committerBill Wendling <wendling@ncsa.uiuc.edu>2000-11-03 20:29:11 (GMT)
commitfee0dc2bb63617ec1ea6c8f09b3ff01e798a2e85 (patch)
tree936555cfbf88e5f348d406a054e4881173223643 /configure.in
parentada3710bc71fc8781a69cb0d87718dc608a9e553 (diff)
downloadhdf5-fee0dc2bb63617ec1ea6c8f09b3ff01e798a2e85.zip
hdf5-fee0dc2bb63617ec1ea6c8f09b3ff01e798a2e85.tar.gz
hdf5-fee0dc2bb63617ec1ea6c8f09b3ff01e798a2e85.tar.bz2
[svn-r2798] Purpose:
Bug Fix...AGAIN! Description: The logic to create the DYNAMIC_DIRS macro was accepting such things as -lnoop_stubs which would cause libtools to barf. Solution: I'm pretty sure I fixed this once before. The change was lost. I now test to make sure that the flag I'm adding has a "-L" prefix on it...
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in16
1 files changed, 10 insertions, 6 deletions
diff --git a/configure.in b/configure.in
index 7a6733d..74d5125 100644
--- a/configure.in
+++ b/configure.in
@@ -1406,15 +1406,19 @@ dnl
DYNAMIC_DIRS=""
if test -n "$LDFLAGS"; then
for d in $LDFLAGS ; do
- d=`echo $d | sed -e 's/-L//g'`
case "$d" in
- .*)
- dnl If the path isn't absolute, make it so by prepending the
- dnl ROOT directory to it.
- d=${ROOT}/$d
+ -L.*)
+ d=`echo $d | sed -e 's/-L//g'`
+ case "$d" in
+ .*)
+ dnl If the path isn't absolute, make it so by
+ dnl prepending the ROOT directory to it.
+ d=${ROOT}/$d
+ ;;
+ esac
+ DYNAMIC_DIRS="-R${d} $DYNAMIC_DIRS"
;;
esac
- DYNAMIC_DIRS="-R${d} $DYNAMIC_DIRS"
done
fi
AC_SUBST(DYNAMIC_DIRS)