summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorJames Laird <jlaird@hdfgroup.org>2005-02-21 21:30:49 (GMT)
committerJames Laird <jlaird@hdfgroup.org>2005-02-21 21:30:49 (GMT)
commit643e9a38bd78fcf6c16127731693e6720bc6b22b (patch)
tree4daf788deb468f597976c3ad8adb5f6de060b0b4 /configure.in
parentf712d13301d9649a16beb8b3e6e9456a6c9b1fc1 (diff)
downloadhdf5-643e9a38bd78fcf6c16127731693e6720bc6b22b.zip
hdf5-643e9a38bd78fcf6c16127731693e6720bc6b22b.tar.gz
hdf5-643e9a38bd78fcf6c16127731693e6720bc6b22b.tar.bz2
[svn-r10062] Purpose:
Bug fix Description: Discovered two small bugs. When MAKE is defined as the empty string, a test in configure incorrectly identifies it as pmake. Skipped this test if $MAKE is the empty string. Two .h5 files produced by a test in the hl directory were not cleaned. Updated the Makefile.am. Platforms tested: heping, modi4 (very minor changes)
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in8
1 files changed, 6 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 75e1cc8..26caaa6 100644
--- a/configure.in
+++ b/configure.in
@@ -565,7 +565,10 @@ dnl These errors can be changed to warnings using the -V flag.
dnl
AC_SUBST(AM_MAKEFLAGS) AM_MAKEFLAGS=""
-AC_MSG_CHECKING([whether make will build with undefined variables])
+dnl Don't run test if MAKE is defined but is the empty string
+if test ${MAKE}; then
+
+ AC_MSG_CHECKING([whether make will build with undefined variables])
cat >maketest <<EOF
foo: \$(UNDEFINED) \$(UNDEFINED2)
@@ -579,7 +582,8 @@ EOF
AM_MAKEFLAGS="\-V"
fi
-rm maketest
+ rm maketest
+fi
dnl ----------------------------------------------------------------------
dnl Production flags? Save the value in $CONFIG_MODE so we have it for