summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorMike McGreevy <mamcgree@hdfgroup.org>2009-08-12 18:55:25 (GMT)
committerMike McGreevy <mamcgree@hdfgroup.org>2009-08-12 18:55:25 (GMT)
commit4598a59f86eaf9db3d838dbc367db494f8ef41f1 (patch)
tree4aa015e8e7f27f1d6f38fc7abcb278e4bb443691 /configure.in
parenteb3fc461a4baa1a5d60b852ef7a9e80437462d5e (diff)
downloadhdf5-4598a59f86eaf9db3d838dbc367db494f8ef41f1.zip
hdf5-4598a59f86eaf9db3d838dbc367db494f8ef41f1.tar.gz
hdf5-4598a59f86eaf9db3d838dbc367db494f8ef41f1.tar.bz2
[svn-r17345] Purpose:
Updating autotools Description: Installed new autotools and used them to reconfigure HDF5. - Automake upgraded to 1.11 - Autoconf upgraded to 2.64 - bin/reconfigure script edited to use new versions (on jam), and run to generate new configure script and Makefile.in's. - configure.in script edited to add "_cv_" to all AC_CACHE_VAL strings (in order to comply with new autoconf standard). Tested: Tested on machines jam, smirom, liberty, linew. Tested w/ features c++, fortran, parallel. Tested w/ compilers gcc, pgcc, icc. Further testing via Daily Tests should catch any other outliers. Upon passing DT's, I'll propogate the new tools into 1.8, hdf4, et cetera.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in18
1 files changed, 9 insertions, 9 deletions
diff --git a/configure.in b/configure.in
index 972cb36..881051b 100644
--- a/configure.in
+++ b/configure.in
@@ -2686,7 +2686,7 @@ dnl bug also occurs at SGI IRIX 6.5 C with compiler version lower than or equal
dnl In case people still use the old compiler, we keep this flag.
AC_MSG_CHECKING([if irregular hyperslab optimization code works inside MPI-IO])
-AC_CACHE_VAL([hdf5_mpi_complex_derived_datatype_works],[hdf5_mpi_complex_derived_datatype_works=yes])
+AC_CACHE_VAL([hdf5_cv_mpi_complex_derived_datatype_works],[hdf5_mpi_complex_derived_datatype_works=yes])
if test ${hdf5_mpi_complex_derived_datatype_works} = "yes"; then
AC_DEFINE([MPI_COMPLEX_DERIVED_DATATYPE_WORKS], [1],
@@ -2705,7 +2705,7 @@ dnl and SGI altix. For those systems, we have to turn off this feature and use i
dnl
AC_MSG_CHECKING([if MPI-IO can do collective IO when one or more processes don't do IOs])
-AC_CACHE_VAL([hdf5_mpi_special_collective_io_works],[hdf5_mpi_special_collective_io_works=yes])
+AC_CACHE_VAL([hdf5_cv_mpi_special_collective_io_works],[hdf5_mpi_special_collective_io_works=yes])
if test ${hdf5_mpi_special_collective_io_works} = "yes"; then
AC_DEFINE([MPI_SPECIAL_COLLECTIVE_IO_WORKS], [1],
@@ -2834,7 +2834,7 @@ AC_ARG_ENABLE([direct-vfd],
[DIRECT_VFD=$enableval], [DIRECT_VFD=yes])
if test "$DIRECT_VFD" = "yes"; then
- AC_CACHE_VAL([hdf5_direct_io],
+ AC_CACHE_VAL([hdf5_cv_direct_io],
[AC_TRY_RUN([
#include <sys/types.h>
#include <sys/stat.h>
@@ -2994,7 +2994,7 @@ AC_MSG_CHECKING([if converting from long double to integers works])
if test ${ac_cv_sizeof_long_double} = 0; then
hdf5_ldouble_to_integer_works=${hdf5_ldouble_to_integer_works=no}
else
- AC_CACHE_VAL([hdf5_ldouble_to_integer_works],
+ AC_CACHE_VAL([hdf5_cv_ldouble_to_integer_works],
[AC_TRY_RUN([
int main(void)
{
@@ -3144,7 +3144,7 @@ dnl than 0.5.
dnl
AC_MSG_CHECKING([if accurately roundup converting floating-point to unsigned long long values])
-AC_CACHE_VAL([hdf5_fp_to_ullong_accurate],
+AC_CACHE_VAL([hdf5_cv_fp_to_ullong_accurate],
[AC_TRY_RUN([
int main(void)
{
@@ -3181,7 +3181,7 @@ dnl during conversion.
dnl
AC_MSG_CHECKING([if right maximum converting floating-point to unsigned long long values])
-AC_CACHE_VAL([hdf5_fp_to_ullong_right_maximum],
+AC_CACHE_VAL([hdf5_cv_fp_to_ullong_right_maximum],
[AC_TRY_RUN([
int main(void)
{
@@ -3226,7 +3226,7 @@ AC_MSG_CHECKING([if correctly converting long double to unsigned int values])
if test ${ac_cv_sizeof_long_double} = 0; then
hdf5_ldouble_to_uint_accurate=${hdf5_ldouble_to_uint_accurate=no}
else
- AC_CACHE_VAL([hdf5_ldouble_to_uint_accurate],
+ AC_CACHE_VAL([hdf5_cv_ldouble_to_uint_accurate],
[AC_TRY_RUN([
int main(void)
{
@@ -3428,7 +3428,7 @@ AC_MSG_CHECKING([if correctly converting long double to (unsigned) long long val
if test ${ac_cv_sizeof_long_double} = 0; then
hdf5_ldouble_to_llong_accurate=${hdf5_ldouble_to_llong_accurate=no}
else
- AC_CACHE_VAL([hdf5_ldouble_to_llong_accurate],
+ AC_CACHE_VAL([hdf5_cv_ldouble_to_llong_accurate],
[AC_TRY_RUN([
int main(void)
{
@@ -3489,7 +3489,7 @@ AC_MSG_CHECKING([if correctly converting (unsigned) long long to long double val
if test ${ac_cv_sizeof_long_double} = 0; then
hdf5_llong_to_ldouble_correct=${hdf5_llong_to_ldouble_correct=no}
else
- AC_CACHE_VAL([hdf5_llong_to_ldouble_correct],
+ AC_CACHE_VAL([hdf5_cv_llong_to_ldouble_correct],
[AC_TRY_RUN([
int main(void)
{