summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorMike McGreevy <mamcgree@hdfgroup.org>2009-10-09 20:12:06 (GMT)
committerMike McGreevy <mamcgree@hdfgroup.org>2009-10-09 20:12:06 (GMT)
commit7f0eb8e04e6de4bde7123701cedf7fd769d6196a (patch)
tree3a1bf31fe8871af8f8c306db8719b18e47225850 /configure.in
parent492da787dd6f21a159c3dfbd74ecf44653177cee (diff)
downloadhdf5-7f0eb8e04e6de4bde7123701cedf7fd769d6196a.zip
hdf5-7f0eb8e04e6de4bde7123701cedf7fd769d6196a.tar.gz
hdf5-7f0eb8e04e6de4bde7123701cedf7fd769d6196a.tar.bz2
[svn-r17627] Purpose:
Couple quick configure cleanups Description: - Made a few AM_LDFLAGS assignments a bit safer. - Regenerated a couple Makefile.in's via bin/reconfigure to address some typo-fixes that didn't propagate in my last check-in. Tested: - h5committest - Also, I suspect this fix will address a failure on Sandia's clogin2 machine, but Albert currently has no password to gain access, so I have only minimal logs of the failure and no way to test it there. I'll just let the automated tests there determine if indeed I'm right.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index 54c22ee..ecce97a 100644
--- a/configure.in
+++ b/configure.in
@@ -1499,7 +1499,7 @@ case $withval in
AC_CHECK_LIB(dmalloc, dmalloc_shutdown,, LDFLAGS="$saved_LDFLAGS"; unset HAVE_DMALLOC)
- if test -n "$HAVE_DMALLOC"; then
+ if test -n "$HAVE_DMALLOC" -a -n "$dmalloc_lib"; then
AM_LDFLAGS="$AM_LDFLAGS -L$dmalloc_lib"
fi
@@ -1581,7 +1581,7 @@ case $withval in
[LDFLAGS="$saved_LDFLAGS"; unset HAVE_ZLIB])
AC_CHECK_FUNC([compress2], [HAVE_COMPRESS2="yes"])
- if test -n "$HAVE_ZLIB"; then
+ if test -n "$HAVE_ZLIB" -a -n "$zlib_lib"; then
AM_LDFLAGS="$AM_LDFLAGS -L$zlib_lib"
fi
@@ -1673,7 +1673,7 @@ case $withval in
AC_CHECK_LIB([sz], [SZ_BufftoBuffCompress],,
[LDFLAGS="$saved_LDFLAGS"; unset HAVE_SZLIB])
- if test -n "$HAVE_SZLIB"; then
+ if test -n "$HAVE_SZLIB" -a -n "$szlib_lib"; then
AM_LDFLAGS="$AM_LDFLAGS -L$szlib_lib"
fi