summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorScot Breitenfeld <brtnfld@hdfgroup.org>2011-08-24 15:17:49 (GMT)
committerScot Breitenfeld <brtnfld@hdfgroup.org>2011-08-24 15:17:49 (GMT)
commit49d739e9a5a543e4c7989abf1483f8179ea8f4b0 (patch)
tree09e11b3488b4126bf659272fe2526797730339a3 /configure.in
parent5aa22d04da4b4e3bf522effa38462f524e14a831 (diff)
downloadhdf5-49d739e9a5a543e4c7989abf1483f8179ea8f4b0.zip
hdf5-49d739e9a5a543e4c7989abf1483f8179ea8f4b0.tar.gz
hdf5-49d739e9a5a543e4c7989abf1483f8179ea8f4b0.tar.bz2
[svn-r21306] Description:
Changed the minimum required version for the pgi compiler to be 11.7, 11.3 version fails in tH5P_F03.f90 when the option -fast is used (i.e. production mode) f_ptr = C_LOC(rd_c) CALL H5Pget_fill_value_f(dcpl, comp_type_id, f_ptr, error) it returns all zeros, version 11.7 does not have this problem. tested: jam koala (pgi, 11.3 and 11.7)
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index 2d632e2..6c6bef5 100644
--- a/configure.in
+++ b/configure.in
@@ -608,16 +608,16 @@ if test "X$HDF_FORTRAN" = "Xyes"; then
vers_major=[`${FC} -V 2>&1 | grep 'pgf' | grep -o ' [0-9]*\.' | sed -e 's/[^0-9]//g'`]
vers_minor=[`${FC} -V 2>&1 | grep 'pgf' | grep -o '\.[0-9]*\-' | sed -e 's/[^0-9]//g'`]
- if test -n "$vers_major" && test "$vers_major" -gt 10; then
+ if test -n "$vers_major" && test "$vers_major" -gt 11; then
HAVE_FORTRAN_2003="yes"
echo $HAVE_FORTRAN_2003
else
- if test -n "$vers_major" && test "$vers_major" = 10 && test -n "$vers_minor" && test "$vers_minor" -gt 4; then
+ if test -n "$vers_major" && test "$vers_major" = 11 && test -n "$vers_minor" && test "$vers_minor" -gt 6; then
HAVE_FORTRAN_2003="yes"
echo $HAVE_FORTRAN_2003
else
echo $HAVE_FORTRAN_2003
- AC_MSG_ERROR([Only The Portland Group Compiler, Version >= 10.4-0 F2003 supported; remove --enable-fortran2003])
+ AC_MSG_ERROR([Only The Portland Group Compiler, Version >= 11.7-0 F2003 supported; remove --enable-fortran2003])
fi
fi
fi