summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorQuincey Koziol <koziol@hdfgroup.org>2000-01-30 00:37:28 (GMT)
committerQuincey Koziol <koziol@hdfgroup.org>2000-01-30 00:37:28 (GMT)
commit0fd1ac674010b6b45a40ef06bd38d966aca03d59 (patch)
tree6ce27506768ff5d9cc5be29e11d9befc018ab011 /configure.in
parent43ddb0f2c42065cbe3b0d1cdc2295177f658c5c6 (diff)
downloadhdf5-0fd1ac674010b6b45a40ef06bd38d966aca03d59.zip
hdf5-0fd1ac674010b6b45a40ef06bd38d966aca03d59.tar.gz
hdf5-0fd1ac674010b6b45a40ef06bd38d966aca03d59.tar.bz2
[svn-r1951] Tweaks to detect the shared libraries on NCSA's systems, so that Albert's
automated tests will work correctly on arabica.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index c28ddc0..239e537 100644
--- a/configure.in
+++ b/configure.in
@@ -412,6 +412,12 @@ dnl NCSA keeps hdf4 in a funny place, but for most sites we don't want these.
test -d /usr/ncsa/include && CPPFLAGS="$CPPFLAGS -I/usr/ncsa/include"
test -d /usr/ncsa/lib && LDFLAGS="$LDFLAGS -L/usr/ncsa/lib"
+AC_SUBST(NCSA_LT_LINK_EXE)
+NCSA_LT_LINK_EXE=
+if test -d /usr/ncsa/lib; then
+ NCSA_LT_LINK_EXE="$NCSA_LT_LINK_EXE -rpath /usr/ncsa/lib"
+fi
+
AC_ARG_WITH(hdf4,[ --with-hdf4=INC,LIB Use the HDF4 library],,withval=yes)
case $withval in
yes)