summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorJames Laird <jlaird@hdfgroup.org>2006-03-30 23:08:50 (GMT)
committerJames Laird <jlaird@hdfgroup.org>2006-03-30 23:08:50 (GMT)
commit6864ebdd6aeb44aa86193f7723b872dbf1ed26fa (patch)
tree205c2df353cdf29ad349ebe207b4ca3afcd7335e /configure.in
parent437418e7ca67f404b0529b07a79d1497e92462f0 (diff)
downloadhdf5-6864ebdd6aeb44aa86193f7723b872dbf1ed26fa.zip
hdf5-6864ebdd6aeb44aa86193f7723b872dbf1ed26fa.tar.gz
hdf5-6864ebdd6aeb44aa86193f7723b872dbf1ed26fa.tar.bz2
[svn-r12183] Purpose:
Configure cleanup Description: Removed unused macros, migrated to non-depreciated macros. Solution: The changes to use standard AC_TRY_LIB macros earlier this week seem not to have broken anything, so I deleted the local macros in acsite.m4 (with an eye to eventually deleting the rest of the file and using only autoconf-supported macros). Replaced the depreciated AC_TRY_LIB with AC_LIB_IFELSE to shut up warnings during reconfigure. Platforms tested: mir, copper (should be just cleanup)
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 3f31a2e..8f32823 100644
--- a/configure.in
+++ b/configure.in
@@ -2160,7 +2160,7 @@ case "X-$enable_parallel" in
AC_LANG_PUSH(Fortran)
dnl Try link a simple MPI program. If fail, try again with -lmpi.
- AC_TRY_LINK(, [
+ AC_LINK_IFELSE([
include 'mpif.h'
integer:: ierr
call mpi_file_open( ierr )],,
@@ -2172,7 +2172,7 @@ case "X-$enable_parallel" in
dnl Then try link a simple MPI-IO program. If fail, try again with
dnl -lmpio.
if test "X$PARALLEL" = "Xyes"; then
- AC_TRY_LINK(, [
+ AC_LINK_IFELSE([
include 'mpif.h'
integer:: ierr
call mpi_file_open( ierr )],,