summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorJames Laird <jlaird@hdfgroup.org>2006-04-26 21:19:21 (GMT)
committerJames Laird <jlaird@hdfgroup.org>2006-04-26 21:19:21 (GMT)
commitab2c2e643c4fba57d72049e8b134f8007924440e (patch)
tree29d443ec587a1a8c85fcd9431cccf4a3315897e3 /configure.in
parent49ae8df461a3da91851749a3630a3c2eed47b182 (diff)
downloadhdf5-ab2c2e643c4fba57d72049e8b134f8007924440e.zip
hdf5-ab2c2e643c4fba57d72049e8b134f8007924440e.tar.gz
hdf5-ab2c2e643c4fba57d72049e8b134f8007924440e.tar.bz2
[svn-r12306] Purpose:
Bug fix Description: Removed some extra compiler flags that were being added in configure Solution: After my previous changes, some of autoconf's macros were realizing that we had no CFLAGS defined and were helpfully supplying some to us, which were causing errors on some platforms. Initializing all of the *FLAGS variables prevented this from happening. Platforms tested: mir (minor change)
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in15
1 files changed, 11 insertions, 4 deletions
diff --git a/configure.in b/configure.in
index 7b7ce2b..d0086ec 100644
--- a/configure.in
+++ b/configure.in
@@ -81,6 +81,12 @@ AC_SUBST([H5_CPPFLAGS])
AC_SUBST([H5_FCFLAGS])
AC_SUBST([H5_CXXFLAGS])
+dnl Make sure flags are set to something (otherwise macros may set them later).
+CFLAGS="${CFLAGS}"
+CPPFLAGS="${CPPFLAGS}"
+CXXFLAGS="${CXXFLAGS}"
+FCFLAGS="${FCFLAGS}"
+
dnl Different compilers may need default libraries. They are specified in
dnl the config/* files, so we put this statement here so that it'll be
dnl set by the code which follows...
@@ -2353,6 +2359,7 @@ else
AC_MSG_RESULT([no])
fi
+
dnl ----------------------------------------------------------------------
dnl Check to see whether MPI-IO can do collective IO successfully when one or more processes don't do
dnl any IOs.
@@ -3439,11 +3446,11 @@ PRINT "$CC"
PRINT_N " CFLAGS / H5_CFLAGS"
PRINT "$CFLAGS"
-PRINT "$H5_CFLAGS"
+PRINT " $H5_CFLAGS"
PRINT_N " CPPFLAGS / H5_CPPFLAGS"
PRINT "$CPPFLAGS"
-PRINT "$H5_CPPFLAGS"
+PRINT " $H5_CPPFLAGS"
PRINT_N " LDFLAGS"
PRINT "$LDFLAGS"
@@ -3485,7 +3492,7 @@ if test X$HDF_CXX = Xyes; then
PRINT_N " CXXFLAGS / H5_CXXFLAGS"
PRINT "$CXXFLAGS"
- PRINT "$H5_CXXFLAGS"
+ PRINT " $H5_CXXFLAGS"
fi
PRINT_N " Fortran"
@@ -3496,7 +3503,7 @@ if test X$HDF_FORTRAN = Xyes; then
PRINT_N " FCFLAGS / H5_FCFLAGS"
PRINT "$FCFLAGS"
- PRINT "$H5_FCFLAGS"
+ PRINT " $H5_FCFLAGS"
fi
PRINT ""