summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorAlbert Cheng <acheng@hdfgroup.org>2000-03-01 23:56:22 (GMT)
committerAlbert Cheng <acheng@hdfgroup.org>2000-03-01 23:56:22 (GMT)
commitb70c49d253ac81ee4b53e3f37900061744edd04a (patch)
tree3606d61bde3b38414855a377924cafd7a9c4f84f /configure.in
parent2be532445cd15ce80afd49127e8ddbc3175d7ac8 (diff)
downloadhdf5-b70c49d253ac81ee4b53e3f37900061744edd04a.zip
hdf5-b70c49d253ac81ee4b53e3f37900061744edd04a.tar.gz
hdf5-b70c49d253ac81ee4b53e3f37900061744edd04a.tar.bz2
[svn-r1995] configure.in:
Makefile.in: acconfig.h: src/H5F.c: src/H5FDdpss.c: src/H5FDdpss.h: src/H5config.h.in: test/dpss_read.c: test/dpss_write.c: Changed the name DPSS to GRIDSTORAGE since that is the real name of the API from ANL. DPSS is just one of the protocols it can use. Changed a bug in the --with-ssl option. Makefile.in: Removed the copying of Makefile.dist since it caused problems when doing a make distclean in a --srcdir configured directory.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in58
1 files changed, 29 insertions, 29 deletions
diff --git a/configure.in b/configure.in
index 33d1659..3e213d1 100644
--- a/configure.in
+++ b/configure.in
@@ -496,14 +496,14 @@ case $withval in
esac
dnl ----------------------------------------------------------------------
-dnl Is SSL library present? It is needed by the DPSS driver.
+dnl Is SSL library present? It is needed by the Grid Storage driver.
dnl
AC_SUBST(SSL)
SSL=yes
AC_ARG_WITH(ssl,[ --with-ssl=LIB Use SSL libs from LIB ],,)
-if test "X-" != "X-$with_ssl_libpath"; then
- LDFLAGS="$LDFLAGS -L$with_ssl_libpath"
+if test "X-" != "X-$with_ssl"; then
+ LDFLAGS="$LDFLAGS -L$with_ssl"
fi
AC_CHECK_LIB(crypto,main,,unset SSL)
@@ -574,7 +574,7 @@ if test "X-" != "X-$GASS"; then
fi
dnl ----------------------------------------------------------------------
-dnl Is GLOBUS Library present? It is needed by the DPSS driver.
+dnl Is GLOBUS Library present? It is needed by the Grid Storage driver.
dnl
AC_SUBST(GLOBUS)
GLOBUS=yes
@@ -645,54 +645,54 @@ if test "X-" != "X-$GLOBUS"; then
fi
dnl ----------------------------------------------------------------------
-dnl Is DPSS present? If so then we can compile in the DPSS driver.
+dnl Is Grid Storage present? If so then we can compile in the Grid Storage driver.
dnl
-AC_SUBST(DPSS)
-DPSS=yes
-AC_SUBST(TESTDPSS)
-TESTDPSS='$(srcdir)/testdpss'
+AC_SUBST(GRIDSTORAGE)
+GRIDSTORAGE=yes
+AC_SUBST(TESTGRIDSTORAGE)
+TESTGRIDSTORAGE='$(srcdir)/testgridstorage'
-AC_ARG_WITH(dpss,
- [ --with-dpss=INC,LIB Use the Globus DPSS driver [default=no]],
+AC_ARG_WITH(gridstorage,
+ [ --with-gridstorage=INC,LIB Use the Globus Grid Storage driver [default=no]],
,withval=no)
case $withval in
yes)
- AC_CHECK_HEADERS(grid_storage_file.h,,unset DPSS TESTDPSS)
- AC_CHECK_LIB(grid_storage_client,main,,unset DPSS TESTDPSS)
- AC_CHECK_LIB(grid_storage_file,grid_storage_open,,unset DPSS TESTDPSS)
+ AC_CHECK_HEADERS(grid_storage_file.h,,unset GRIDSTORAGE TESTGRIDSTORAGE)
+ AC_CHECK_LIB(grid_storage_client,main,,unset GRIDSTORAGE TESTGRIDSTORAGE)
+ AC_CHECK_LIB(grid_storage_file,grid_storage_open,,unset GRIDSTORAGE TESTGRIDSTORAGE)
;;
no)
- AC_MSG_CHECKING(for DPSS)
+ AC_MSG_CHECKING(for GRIDSTORAGE)
AC_MSG_RESULT(suppressed)
- unset DPSS TESTDPSS
+ unset GRIDSTORAGE TESTGRIDSTORAGE
;;
*)
- dpss_inc="`echo $withval |cut -f1 -d,`"
- if test "X" != "$dpss_inc"; then
+ gridstorage_inc="`echo $withval |cut -f1 -d,`"
+ if test "X" != "$gridstorage_inc"; then
saved_CPPFLAGS="$CPPFLAGS"
- CPPFLAGS="$CPPFLAGS -I$dpss_inc"
+ CPPFLAGS="$CPPFLAGS -I$gridstorage_inc"
AC_CHECK_HEADERS(grid_storage_file.h,,
CPPFLAGS="$saved_CPPFLAGS"
- unset DPSS TESTDPSS
+ unset GRIDSTORAGE TESTGRIDSTORAGE
)
else
AC_CHECK_HEADERS(grid_storage_file.h)
fi
- dpss_lib="`echo $withval |cut -f2 -d, -s`"
- if test "X" != "$dpss_lib"; then
+ gridstorage_lib="`echo $withval |cut -f2 -d, -s`"
+ if test "X" != "$gridstorage_lib"; then
saved_LDFLAGS="$LDFLAGS"
- LDFLAGS="$LDFLAGS -L$dpss_lib"
- AC_CHECK_LIB(grid_storage_client,main,,unset DPSS TESTDPSS)
- AC_CHECK_LIB(grid_storage_file,grid_storage_open,,unset DPSS TESTDPSS)
+ LDFLAGS="$LDFLAGS -L$gridstorage_lib"
+ AC_CHECK_LIB(grid_storage_client,main,,unset GRIDSTORAGE TESTGRIDSTORAGE)
+ AC_CHECK_LIB(grid_storage_file,grid_storage_open,,unset GRIDSTORAGE TESTGRIDSTORAGE)
else
- AC_CHECK_LIB(grid_storage_client,main,,unset DPSS TESTDPSS)
- AC_CHECK_LIB(grid_storage_file,grid_storage_open,,unset DPSS TESTDPSS)
+ AC_CHECK_LIB(grid_storage_client,main,,unset GRIDSTORAGE TESTGRIDSTORAGE)
+ AC_CHECK_LIB(grid_storage_file,grid_storage_open,,unset GRIDSTORAGE TESTGRIDSTORAGE)
fi
;;
esac
-if test "X-" != "X-$DPSS"; then
- AC_DEFINE(HAVE_DPSS)
+if test "X-" != "X-$GRIDSTORAGE"; then
+ AC_DEFINE(HAVE_GRIDSTORAGE)
fi
dnl ----------------------------------------------------------------------