summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorQuincey Koziol <koziol@hdfgroup.org>2003-12-31 20:36:37 (GMT)
committerQuincey Koziol <koziol@hdfgroup.org>2003-12-31 20:36:37 (GMT)
commit4da7b1ee9b462925818cf704c89a72fef5f55e4d (patch)
treee9f04f8824aa714fb2346ed540a4b291ce2bb0c1 /configure.in
parentb0b020d422b493228c00449391552bdfc50a33c2 (diff)
downloadhdf5-4da7b1ee9b462925818cf704c89a72fef5f55e4d.zip
hdf5-4da7b1ee9b462925818cf704c89a72fef5f55e4d.tar.gz
hdf5-4da7b1ee9b462925818cf704c89a72fef5f55e4d.tar.bz2
[svn-r8009] Purpose:
Bug fix Description: Add special-case handling to floating-point conversion tests to avoid problems with denormalized values on Cray T3E & T90 platforms. (Still not working on Cray SV1, but at least it's closer). Solution: Detect denormalized values and don't try to operate on them on the Crays. Platforms tested: FreeBSD 4.9 (sleipnir) Cray T3E (hubble.cray.com) Cray T90 (gypsy.cray.com)
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in19
1 files changed, 18 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index c2e9ef8..df912a1 100644
--- a/configure.in
+++ b/configure.in
@@ -1647,7 +1647,7 @@ AC_MSG_RESULT([no]))
dnl ----------------------------------------------------------------------
dnl Check for functions.
dnl
-AC_CHECK_FUNCS(fork gethostname getpwuid getrusage)
+AC_CHECK_FUNCS(fork frexpf frexpl gethostname getpwuid getrusage)
AC_CHECK_FUNCS(BSDgettimeofday longjmp setsysinfo sigaction)
AC_CHECK_FUNCS(signal snprintf vsnprintf strdup system waitpid)
@@ -2364,6 +2364,23 @@ if test 1 = 2; then
fi
dnl ----------------------------------------------------------------------
+dnl Set the flag to indicate that the machine can handle converting
+dnl denormalized floating-point values.
+dnl (This flag should be set for all machines, except for the Crays, where
+dnl the cache value is set in it's config file)
+dnl
+AC_MSG_CHECKING([if converting denormalized floating-point values is possible])
+AC_CACHE_VAL([hdf5_cv_convert_denormal_float], [hdf5_cv_convert_denormal_float=yes])
+
+if test ${hdf5_cv_convert_denormal_float} = "yes"; then
+ AC_DEFINE([CONVERT_DENORMAL_FLOAT], [1],
+ [Define if your system can handle converting denormalized floating-point values.])
+ AC_MSG_RESULT([yes])
+else
+ AC_MSG_RESULT([no])
+fi
+
+dnl ----------------------------------------------------------------------
dnl Set some variables for general configuration information to be saved
dnl and installed with the libraries.
dnl