summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorAlbert Cheng <acheng@hdfgroup.org>2010-06-11 23:37:33 (GMT)
committerAlbert Cheng <acheng@hdfgroup.org>2010-06-11 23:37:33 (GMT)
commit4e4c5d3e0f16271330443688dc4afcf1a41aa830 (patch)
treeaf4d537bbd2360285837edfc1afa70c655a292c3 /configure.in
parent935bf228d3a54428bbd44d1561ec4a521d4462eb (diff)
downloadhdf5-4e4c5d3e0f16271330443688dc4afcf1a41aa830.zip
hdf5-4e4c5d3e0f16271330443688dc4afcf1a41aa830.tar.gz
hdf5-4e4c5d3e0f16271330443688dc4afcf1a41aa830.tar.bz2
[svn-r18992] Bug Fix: (ID 1921)
PHDF5 changed to use "mpiexec", instead of mpirun, as the default MPI applications startup command as defined in the MPI-2 definition, section 4.1. Note that only mpich related (using mpicc command) definitions are changed to mpiexec. Other favors like hcc, AIX, champion, are not changed since I don't have a way to verify them yet. Tested: jam and amani, using both current and new mpich. Did not h5committested since this affects PHDF5 configure only.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in38
1 files changed, 19 insertions, 19 deletions
diff --git a/configure.in b/configure.in
index 435b229..f3448b9 100644
--- a/configure.in
+++ b/configure.in
@@ -681,7 +681,7 @@ dnl RUNSERIAL -- This is a command which will be prepended to
dnl the executable name to run the executable using
dnl a single process. For serial versions of the
dnl library this will normally be empty. For parallel
-dnl versions it might be something like `mpirun -np 1'.
+dnl versions it might be something like `mpiexec -n 1'.
dnl The value of this variable is substituted in *.in
dnl files.
dnl
@@ -706,15 +706,15 @@ dnl ----------------------------------------------------------------------
dnl If the compiler is obviously a parallel compiler then we're building
dnl a parallel version of hdf5 and should define HAVE_PARALLEL. Furthermore,
dnl the name of the compiler might tell us how to run the resulting
-dnl executable. For `mpicc' the executable should be run with `mpirun' from
+dnl executable. For `mpicc' the executable should be run with `mpiexec' from
dnl the same directory as mpicc if it exists.
dnl
case "$CC_BASENAME" in
mpicc)
- dnl The mpich compiler. Use mpirun from the same directory if it
+ dnl The mpich compiler. Use mpiexec from the same directory if it
dnl exists.
PARALLEL=mpicc
- AC_MSG_CHECKING([for mpirun])
+ AC_MSG_CHECKING([for mpiexec])
dnl Find the path where mpicc is located.
cmd="`echo $CC | cut -f1 -d' '`"
@@ -728,13 +728,13 @@ case "$CC_BASENAME" in
done
fi
- dnl Is there an mpirun at that path?
- if test -x $path/mpirun; then
- AC_MSG_RESULT([$path/mpirun])
+ dnl Is there an mpiexec at that path?
+ if test -x $path/mpiexec; then
+ AC_MSG_RESULT([$path/mpiexec])
RUNSERIAL="${RUNSERIAL:-none}"
if test -z "$RUNPARALLEL"; then
- RUNPARALLEL="$path/mpirun -np \$\${NPROCS:=3}"
+ RUNPARALLEL="$path/mpiexec -n \$\${NPROCS:=3}"
fi
else
AC_MSG_RESULT([none])
@@ -811,7 +811,7 @@ dnl If the Fortran compiler is obviously a parallel compiler then we're
dnl building a parallel version of hdf5 and should define HAVE_PARALLEL.
dnl Furthermore, the name of the compiler might tell us how to run the
dnl resulting executable. For `mpif90' the executable should be run with
-dnl `mpirun' from the same directory as mpif90 if it exists.
+dnl `mpiexec' from the same directory as mpif90 if it exists.
dnl
if test "X$HDF_FORTRAN" = "Xyes"; then
dnl Change to the Fortran 90 language
@@ -819,10 +819,10 @@ if test "X$HDF_FORTRAN" = "Xyes"; then
case "$FC" in
*mpif90*)
- dnl The Fortran mpich compiler. Use mpirun from the same directory
+ dnl The Fortran mpich compiler. Use mpiexec from the same directory
dnl if it exists.
PARALLEL=mpif90
- AC_MSG_CHECKING([for mpirun])
+ AC_MSG_CHECKING([for mpiexec])
dnl Find the path where mpif90 is located.
cmd=`echo $FC |cut -f1 -d' '`
@@ -836,13 +836,13 @@ if test "X$HDF_FORTRAN" = "Xyes"; then
done
fi
- dnl Is there an mpirun at that path?
- if test -x $path/mpirun; then
- AC_MSG_RESULT([$path/mpirun])
+ dnl Is there an mpiexec at that path?
+ if test -x $path/mpiexec; then
+ AC_MSG_RESULT([$path/mpiexec])
RUNSERIAL="${RUNSERIAL:-none}"
if test -z "$RUNPARALLEL"; then
- RUNPARALLEL="$path/mpirun -np \$\${NPROCS:=2}"
+ RUNPARALLEL="$path/mpiexec -n \$\${NPROCS:=2}"
fi
else
AC_MSG_RESULT([none])
@@ -2593,9 +2593,9 @@ case "X-$enable_parallel" in
AC_LANG_POP(Fortran)
fi
- dnl Set RUNPARALLEL to mpirun if not set yet.
+ dnl Set RUNPARALLEL to mpiexec if not set yet.
dnl Check for building on Cray if RUNPARALLEL is not yet set by checking
- dnl for 'aprun' command (which is the parallel job launcher, like mpirun).
+ dnl for 'aprun' command (which is the parallel job launcher, like mpiexec).
if test "X$PARALLEL" = "Xyes" -a -z "$RUNPARALLEL"; then
dnl Find the path where aprun is located.
for path in `echo $PATH | ${TR} ":" " "`; do
@@ -2606,9 +2606,9 @@ case "X-$enable_parallel" in
done
fi
- dnl Set RUNPARALLEL to mpirun if not set yet.
+ dnl Set RUNPARALLEL to mpiexec if not set yet.
if test "X$PARALLEL" = "Xyes" -a -z "$RUNPARALLEL"; then
- RUNPARALLEL="mpirun -np \$\${NPROCS:=3}"
+ RUNPARALLEL="mpiexec -n \$\${NPROCS:=3}"
fi
;;