summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorAlbert Cheng <acheng@hdfgroup.org>2010-10-28 17:19:30 (GMT)
committerAlbert Cheng <acheng@hdfgroup.org>2010-10-28 17:19:30 (GMT)
commit751b307df9208102042e205c360ef184c76f10fc (patch)
tree96888c46a5f1f57de14c7c63b051ae3b83b0278e /configure.in
parenta654e61d6c559cef47732fd2d6ef3395237d5df9 (diff)
downloadhdf5-751b307df9208102042e205c360ef184c76f10fc.zip
hdf5-751b307df9208102042e205c360ef184c76f10fc.tar.gz
hdf5-751b307df9208102042e205c360ef184c76f10fc.tar.bz2
[svn-r19694] Changed the default NPROCS from 3 to 6 for MPI tests.
Tested: in jam only since that is that only parallel tests h5committest would have done.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in14
1 files changed, 7 insertions, 7 deletions
diff --git a/configure.in b/configure.in
index 5a20beb..c75c4a7 100644
--- a/configure.in
+++ b/configure.in
@@ -694,9 +694,9 @@ dnl the executable name to run the executable on
dnl multiple processors. For the serial library the
dnl value will normally be the empty string. For
dnl parallel library it should be something like
-dnl `mpi -np $$NPROCS' where NPROCS will eventually
-dnl contain the number of processors on which to run
-dnl the executable (the double dollarsigns are to
+dnl "mpiexec -n \$\${NPROCS:=6}" where NPROCS will
+dnl eventually contain the number of processors on which
+dnl to run the executable (the double dollarsigns are to
dnl protect the expansion until make executes the
dnl command). The value of this variable is
dnl substituted in *.in files.
@@ -738,7 +738,7 @@ case "$CC_BASENAME" in
RUNSERIAL="${RUNSERIAL:-none}"
if test -z "$RUNPARALLEL"; then
- RUNPARALLEL="$path/mpiexec -n \$\${NPROCS:=3}"
+ RUNPARALLEL="$path/mpiexec -n \$\${NPROCS:=6}"
fi
else
AC_MSG_RESULT([none])
@@ -792,7 +792,7 @@ if test "X$HDF_FORTRAN" = "Xyes"; then
RUNSERIAL="${RUNSERIAL:-none}"
if test -z "$RUNPARALLEL"; then
- RUNPARALLEL="$path/mpiexec -n \$\${NPROCS:=2}"
+ RUNPARALLEL="$path/mpiexec -n \$\${NPROCS:=6}"
fi
else
AC_MSG_RESULT([none])
@@ -2550,7 +2550,7 @@ case "X-$enable_parallel" in
dnl Find the path where aprun is located.
for path in `echo $PATH | ${TR} ":" " "`; do
if test -x $path/aprun; then
- RUNPARALLEL="aprun -q -n \$\${NPROCS:=3}"
+ RUNPARALLEL="aprun -q -n \$\${NPROCS:=6}"
break;
fi
done
@@ -2558,7 +2558,7 @@ case "X-$enable_parallel" in
dnl Set RUNPARALLEL to mpiexec if not set yet.
if test "X$PARALLEL" = "Xyes" -a -z "$RUNPARALLEL"; then
- RUNPARALLEL="mpiexec -n \$\${NPROCS:=3}"
+ RUNPARALLEL="mpiexec -n \$\${NPROCS:=6}"
fi
;;