summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorAlbert Cheng <acheng@hdfgroup.org>2010-07-14 15:56:42 (GMT)
committerAlbert Cheng <acheng@hdfgroup.org>2010-07-14 15:56:42 (GMT)
commiteea98ac8cb4743461def87f7d7d2a7d9587d5f8e (patch)
tree598a3678e95fa65c5c9d2f484a5e0517fa7da877 /configure.in
parent3d3d95db0749e0b0dc9fefec17de121db6927d9e (diff)
downloadhdf5-eea98ac8cb4743461def87f7d7d2a7d9587d5f8e.zip
hdf5-eea98ac8cb4743461def87f7d7d2a7d9587d5f8e.tar.gz
hdf5-eea98ac8cb4743461def87f7d7d2a7d9587d5f8e.tar.bz2
[svn-r19068] Bug fix: ID 1921 change mpirun to mpiexec
Removed the recognition of parallel compilers of LAM (hcc) and ChMPIon (cmpicc) since we have no access to these two MPI implementations and decided not to support them any more. Test: Jam using parallel tests: 1. use CC=mpicc and confirmed it is recognized as a parallel compiler; 2. use CC=hcc and confirmed it is NOT recognized as a parallel compiler any more.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in54
1 files changed, 0 insertions, 54 deletions
diff --git a/configure.in b/configure.in
index 7b632fd..26f27ba 100644
--- a/configure.in
+++ b/configure.in
@@ -741,65 +741,11 @@ case "$CC_BASENAME" in
fi
;;
- hcc)
- dnl The LAM compiler. Use mpirun_lam or mpirun from the same directory
- dnl if it exists.
- PARALLEL=hcc
- AC_MSG_CHECKING([for mpirun_lam or mpirun])
-
- dnl Find the path where hcc is located
- cmd="`echo $CC | cut -f1 -d' '`"
- if (echo $cmd | grep / >/dev/null); then
- path="`echo $cmd | sed 's/\(.*\)\/.*$/\1/'`"
- else
- for path in `echo $PATH | ${TR} ":" " "`; do
- if test -x $path/$cmd; then
- break
- fi
- done
- fi
-
- dnl Is there an mpirun_lam or mpirun at that path?
- if test -x $path/mpirun_lam -o -x $path/mpirun; then
- if test -x $path/mpirun_lam; then
- cmd=mpirun_lam
- else
- cmd=mpirun
- fi
- AC_MSG_RESULT([$path/$cmd])
- RUNSERIAL="${RUNSERIAL:-none}"
- if test -z "$RUNPARALLEL"; then
- RUNPARALLEL="$path/$cmd -np \$\${NPROCS:=3}"
- fi
- else
- AC_MSG_RESULT([none])
- fi
- ;;
-
mpcc|mpcc_r)
dnl The IBM compiler
PARALLEL="$CC_BASENAME"
;;
- cmpicc)
- dnl The ChaMPIon compiler on NCSA tungsten. The cmpirun command on tungsten
- dnl isn't in the same path as cmpicc.
- PARALLEL=cmpicc
- AC_MSG_CHECKING([for cmpirun])
-
- dnl Is there an cmpirun?
- if test -x cmpirun; then
- AC_MSG_RESULT([cmpirun])
- RUNSERIAL="${RUNSERIAL:-none}"
-
- if test -z "$RUNPARALLEL"; then
- RUNPARALLEL="cmpirun -np \$\${NPROCS:=3}"
- fi
- else
- AC_MSG_RESULT([none])
- fi
- ;;
-
*)
dnl Probably not a parallel compiler, but if `--enable-parallel'
dnl is defined below then we're still building a parallel hdf5.