summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorRobb Matzke <matzke@llnl.gov>1998-03-18 18:09:16 (GMT)
committerRobb Matzke <matzke@llnl.gov>1998-03-18 18:09:16 (GMT)
commit2fd149a5824c22920d2102b97db8478b2f61d5dd (patch)
tree13d887c221264834f88d100e33acafe6cf9b4038 /configure.in
parent96dd634330502cdde53905c9edbef56028323969 (diff)
downloadhdf5-2fd149a5824c22920d2102b97db8478b2f61d5dd.zip
hdf5-2fd149a5824c22920d2102b97db8478b2f61d5dd.tar.gz
hdf5-2fd149a5824c22920d2102b97db8478b2f61d5dd.tar.bz2
[svn-r325] Changes since 19980317
---------------------- ./MANIFEST ./configure.in ./configure ./Makefile.in ./bin/distdep [NEW] ./config/conclude.in ./config/depend.in ./src/.distdep [NEW] ./test/.distdep [NEW] Added some code so non-GNU systems have a list of dependencies between the .c files and the .h files. Hopefully this works and y'all don't have to keep saying `make clean' each time you change a header. On systems with GNU make, GCC, and Perl, the dependency information is generated automatically from rules in config/depend.in as has always been done. But now extra files called `.distdep' (for `distributable dependencies) are left in each directory and these are part of CVS and thus releases. (A `make dep' will create dependencies on demand without doing anything else.) On systems lacking one or more of the tools above, the various `.distdep' files are inserted into the end of the Makefiles. If you do developement on one of these systems you'll have to update the `.distdep' and/or Makefile by hand, or wait until you have access to a GNU system and do a `make dep'.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in6
1 files changed, 4 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 7f48014..a05925e 100644
--- a/configure.in
+++ b/configure.in
@@ -207,9 +207,11 @@ AC_SUBST_FILE(COMMENCE) COMMENCE=config/commence
AC_SUBST_FILE(CONCLUDE) CONCLUDE=config/conclude
if test "X$GCC" = "Xyes" && test "X$GMAKE" = "Xyes"; then
- AC_SUBST_FILE(DEPEND) DEPEND=config/depend
+ AC_SUBST_FILE(DEPEND1) DEPEND1=config/depend
+ AC_SUBST_FILE(DEPEND2) DEPEND2=/dev/null
else
- AC_SUBST(DEPEND) DEPEND='# Use GNU make/GCC if you want auto dependencies'
+ AC_SUBST_FILE(DEPEND1) DEPEND1=src/.distdep
+ AC_SUBST_FILE(DEPEND2) DEPEND2=test/.distdep
fi
dnl We don't need to say when we're entering directories if we're using