summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorRobb Matzke <matzke@llnl.gov>1998-02-25 20:31:17 (GMT)
committerRobb Matzke <matzke@llnl.gov>1998-02-25 20:31:17 (GMT)
commitad73f18f5e759c4bd3d12c331659a24b54d0c39a (patch)
tree660a8bb32cc118a647757c5ae2321cf9b1ca9073 /configure.in
parentc543632ba5cd609d2e6303fa9cf55685568fa851 (diff)
downloadhdf5-ad73f18f5e759c4bd3d12c331659a24b54d0c39a.zip
hdf5-ad73f18f5e759c4bd3d12c331659a24b54d0c39a.tar.gz
hdf5-ad73f18f5e759c4bd3d12c331659a24b54d0c39a.tar.bz2
[svn-r298] Changes since 19980219
---------------------- ./html/Files.html ./src/H5C.c ./src/H5Cpublic.h ./src/H5Ffamily.c ./src/H5Fprivate.h ./src/H5Fsplit.c ./test/tstab.c Added file-access property functions. The split driver takes file extensions as properties. ./src/H5A.c ./src/H5Aprivate.h Added some comments. Changed H5A_destroy() to call the free function on all the atoms that are destroyed. This fixes a bug where the file boot block isn't updated if the file isn't closed before calling exit(). Removed extra `*' and `&' from some places. ./src/H5AC.c Replaced an occurrence of NO_ADDR with NULL. ./src/H5Odtype.c ./src/H5T.c ./src/H5Tconv.c ./src/H5Tpkg.h Data types of compound members are pointers. ./H5private.h Some changes to make lseek64() work on Irix 5.3 where header files don't realize that `long long' works. ./acconfig.h ./configure.in Removed definition for PHDF5 since it looks like everyone is useing HAVE_PARALLEL now. ./configure.in ./src/H5detec.c Added checks for gethostname() and getpwuid().
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in13
1 files changed, 6 insertions, 7 deletions
diff --git a/configure.in b/configure.in
index faa8108..a5a72fe 100644
--- a/configure.in
+++ b/configure.in
@@ -107,7 +107,7 @@ AC_TYPE_SIZE_T
dnl ----------------------------------------------------------------------
dnl Check for functions.
dnl
-AC_CHECK_FUNCS(lseek64 fseek64)
+AC_CHECK_FUNCS(lseek64 fseek64 getpwuid gethostname)
dnl ----------------------------------------------------------------------
@@ -161,13 +161,12 @@ case "X-$PARALLEL" in
;;
X-mpio|X-yes)
- # Use MPIO. Define PHDF5 in src/H5config.h (comes from ./acconfig.h)
- # and augment the include and library search paths (it doesn't hurt
- # to have extra paths). Then check for header files and libraries.
- # Some extra source files are added to the list also so we don't have
- # to ifdef out the whole file.
+ # Use MPIO. Define HAVE_PARALLEL in src/H5config.h (comes from
+ # ./acconfig.h) and augment the include and library search paths
+ # (it doesn't hurt to have extra paths). Then check for header
+ # files and libraries. Some extra source files are added to the
+ # list also so we don't have to ifdef out the whole file.
AC_MSG_RESULT(mpio)
- AC_DEFINE(PHDF5) dnl THIS WILL GO AWAY SHORTLY!!!
AC_DEFINE(HAVE_PARALLEL)
PARALLEL_SRC='$(PARALLEL_SRC)'
CPPFLAGS="$CPPFLAGS $MPI_INC"