summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorRobb Matzke <matzke@llnl.gov>1999-03-02 17:15:35 (GMT)
committerRobb Matzke <matzke@llnl.gov>1999-03-02 17:15:35 (GMT)
commit116491f0d63d197fabf07856b2c03fb69b187ddf (patch)
treea191664163831cf6cf12939a025dcaf9c7988cb7 /configure.in
parent1f1bfc91bc57bee3d9a7b328695a95f9f24b75c9 (diff)
downloadhdf5-116491f0d63d197fabf07856b2c03fb69b187ddf.zip
hdf5-116491f0d63d197fabf07856b2c03fb69b187ddf.tar.gz
hdf5-116491f0d63d197fabf07856b2c03fb69b187ddf.tar.bz2
[svn-r1112] Changes since 19990301
---------------------- ./INSTALL Reorganized and added some additional examples. ./MANIFEST ./aclocal.m4 [NEW] ./configure.in ./configure [REGENERATED] ./src/H5config.h.in [REGENERATED] ./bin/ltconfig [NEW] ./bin/ltmain.sh [NEW] Added tests to determine how to compile shared libraries and how to link programs with them before the libraries are installed. Also how to install and uninstall shared libraries. The configure step also prints the names of the config files it's trying to load for easier debugging. ./bin/config.guess ./bin/config.sub Replaced with a newer version from GNU. The changes we made to that file to report `irix6.x' and `FreeBSD' without version numbers have been incorporated into configure.in instead. In the future, do not change these two files (see the top of configure.in instead). By the way, this update was required to get shared libraries working. ./config/linux [REMOVED] ./config/linux-gnulibc1 [NEW] ./config/linux-gnu [NEW] ./config/alpha-dec [REMOVED] ./config/alpha-dec-osf4.0 [REMOVED] ./config/dec-osf4.x [NEW] ./config/irix5.3 [REMOVED] ./config/irix5.x [NEW] ./config/irix64 [REMOVED] ./config/freebsd Moved config files around to agree with output from the new config.guess. The linux file was split into gnu (RedHat), gnulibc1, and gnulibc2 versions. The alpha-dec file was removed (I think it was unused) and the alpha-dec-osf4.0 was changed to dec-osf4.x. The irix5.3 file renamed to irix5.x and the irix64 file was renamed to irix6.x. The freebsd file was changed to point to linux-gnulibc1. These changes were tested on: Linux 2.0 Linux 2.1 FreeBSD 3.2 Irix 5.3 Irix64 6.2 Irix64 6.4 HP/UX 10.20 OSF1 4.0 ./config/alphaev56-dec-osf4.x ./config/irix64 Added warnings similar to linux/freebsd about using compilers with known bugs. ./config/commence.in ./config/conclude.in ./src/Makefile.in ./test/Makefile.in ./testpar/Makefile.in ./tools/Makefile.in Added definitions for shared libraries. This has been tested on the following systems: Linux 2.0 Linux 2.1 FreeBSD 3.2 Irix 5.3 Irix64 6.2 Irix64 6.4 HP/UX 10.20 static only OSF1 4.0 If you want to disable use of shared libraries (you probably do for development purposes since it takes a lot longer to compile and because you have to run dynamically linked programs in a special way if the library hasn't been installed) then add `--disable-shared' to the configure command line. This is all documented in the INSTALL file. ./bin/release Temprarily commented out the MANIFEST checking when running under svf since svf is about to be replaced by a newer version. This change only affects error checking during the release process. ./Makefile.dist ./Makefile.in Added `make check' which does the same thing as `make _test' since the former is endorsed by the GNU coding style and people are used to it. The old `make _test' still works too (and so does `make test' if you use GNU make).
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in51
1 files changed, 36 insertions, 15 deletions
diff --git a/configure.in b/configure.in
index db13084..36f86a8 100644
--- a/configure.in
+++ b/configure.in
@@ -4,8 +4,6 @@ dnl
dnl Copyright (C) 1997 National Center for Supercomputing Applications.
dnl All rights reserved.
-
-
dnl ----------------------------------------------------------------------
dnl Initialize configure.
dnl
@@ -50,22 +48,42 @@ dnl OS
dnl VENDOR
dnl CPU
dnl
+dnl If the `OS' ends with a version number then remove it. For instance,
+dnl `freebsd3.1' would become `freebsd'
+case $host_os in
+ freebsd*)
+ host_os_novers=freebsd
+ ;;
+ irix5.*)
+ host_os_novers=irix5.x
+ ;;
+ irix6.*)
+ host_os_novers=irix6.x
+ ;;
+ osf4.*)
+ host_os_novers=osf4.x
+ ;;
+ *)
+ host_os_novers=$host_os
+ ;;
+esac
-AC_MSG_CHECKING(for host config file)
host_config="none"
-for f in $host \
- $host_vendor-$host_os \
- $host_cpu-$host_os \
+for f in $host_cpu-$host_vendor-$host_os_novers \
+ $host_vendor-$host_os_novers \
+ $host_cpu-$host_os_novers \
$host_cpu-$host_vendor \
- $host_os \
+ $host_os_novers \
$host_vendor \
$host_cpu ; do
+ AC_MSG_CHECKING(for config $f)
if test -f config/$f; then
host_config=config/$f
+ AC_MSG_RESULT(found)
break
fi
+ AC_MSG_RESULT(no)
done
-AC_MSG_RESULT($host_config)
if test $host_config != "none"; then
CC_BASENAME="`echo $CC |cut -f1 -d' ' |xargs basename 2>/dev/null`"
. $host_config
@@ -78,7 +96,7 @@ AC_PROG_CC
CC_BASENAME="`echo $CC |cut -f1 -d' ' |xargs basename 2>/dev/null`"
AC_PROG_MAKE_SET
AC_PROG_INSTALL
-AC_PROG_RANLIB
+AM_PROG_LIBTOOL
if test "X$AR" = "X"; then
AC_CHECK_PROGS(AR,ar xar,:,$PATH)
@@ -148,12 +166,15 @@ AC_CHECK_HEADERS(stddef.h)
dnl Windows
AC_CHECK_HEADERS(io.h winsock.h sys/timeb.h)
-dnl The <sys/sysinfo.h> and <sys/proc.h> are needed on the DEC Alpha
-dnl to turn off UAC fixing. We do *not* attempt to locate these files on
-dnl other systems because there are too many problems with including them.
-if test "$host_vendor-$host_cpu" = "dec-alpha"; then
- AC_CHECK_HEADERS(sys/sysinfo.h sys/proc.h)
-fi
+case $host in
+ alpha*-dec*-osf*)
+ dnl The <sys/sysinfo.h> and <sys/proc.h> are needed on the DEC
+ dnl Alpha to turn off UAC fixing. We do *not* attempt to
+ dnl locate these files on other systems because there are too
+ dnl many problems with including them.
+ AC_CHECK_HEADERS(sys/sysinfo.h sys/proc.h)
+ ;;
+esac
dnl ----------------------------------------------------------------------
dnl Data types and their sizes.