summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorRobb Matzke <matzke@llnl.gov>1999-03-19 20:09:50 (GMT)
committerRobb Matzke <matzke@llnl.gov>1999-03-19 20:09:50 (GMT)
commitb93c9e2cf93cfa61eb6200e8be9a444f44fe1e86 (patch)
tree48e3d92a37120aceac6257cfa018815d472e100b /configure.in
parent19e5077f7f3831e7461e5ba5619906063e083cc9 (diff)
downloadhdf5-b93c9e2cf93cfa61eb6200e8be9a444f44fe1e86.zip
hdf5-b93c9e2cf93cfa61eb6200e8be9a444f44fe1e86.tar.gz
hdf5-b93c9e2cf93cfa61eb6200e8be9a444f44fe1e86.tar.bz2
[svn-r1151] Changes since 19990318
---------------------- ./Makefile.in ./configure.in ./configure [REGENERATED] ./src/H5config.h.in [REGENERATED] ./config/commence.in ./config/conclude.in ./config/dec-osf4.x ./config/depend.in ./config/freebsd ./config/linux-gnu ./config/linux-gnulibc1 ./config/linux-gnulibc2 ./config/solaris2.x ./examples/Makefile.in ./src/Makefile.in ./test/Makefile.in ./testpar/Makefile.in ./tools/Makefile.in ./tools/testh5dump.sh Changes that allow hdf5 to be configured and compiled in a directory other than the source directory. This is especially useful if you want to concurrently compile with different compilers and/or compile flags, or if the hdf5 source is on read-only media like a CDROM. The changes were surprisingly easy ;-) Here's what you can do now... $ mkdir /tmp/build1 # or something $ cd /tmp/build1 $ /cdrom/hdf5/configure # where ever the source is $ make Paul, you'll have to change the testh5toh4 script similar to the way I changed testh5dump.sh. I started working on it but then gave up because of a number of problems: (1) I had to comment out all the tests that let h5toh4 choose the output file name because it always tried to put the output file in the same directory as the input file, (2) if path names are used during the h4 dump then they interfere with the diff. The test works fine when run in the source directory, but try this instead: $ gunzip <hdf5-1.1.67.tar.gz |tar xf - $ chmod -R ugo-w hdf5-1.1.67 $ mkdir build $ cd build $ ../hdf5-1.1.67/configure $ make check Dan, I didn't modify the pablo/Makefile.in because I have no way to test it. I think all you need to do is add a couple lines before the @COMMENCE@ line and add a couple search directories for header files. Anyway, it seems like almost an exact duplicate of the src/Makefile.in, so it shouldn't be a problem... ./Makefile.in Removes a few more temporary files during make clean and distclean. ./configure.in I fixed the creation of the time-stamp files so that the initial make doesn't have to regenerated all the makefiles (only GNU make users will see any change). ./src/H5R.c Changed a return type from `intn' to `int' for an API function. ./src/H5detect.c Added the volatile qualifier to a couple more variables. ./tools/h5tools.c Fixed a compiler warning about an unused local. ./tools/h5toh4.c Initialized `optind' to 1 because it's zero on my system. It should always be one on a unix system. ./tools/testh5toh4 Redirected "broken pipe" messages to /dev/null so outut is formatted correctly.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in20
1 files changed, 14 insertions, 6 deletions
diff --git a/configure.in b/configure.in
index a6cad3f..9caff6c 100644
--- a/configure.in
+++ b/configure.in
@@ -87,8 +87,8 @@ for f in $host_cpu-$host_vendor-$host_os \
$host_vendor \
$host_cpu ; do
AC_MSG_CHECKING(for config $f)
- if test -f config/$f; then
- host_config=config/$f
+ if test -f $srcdir/config/$f; then
+ host_config=$srcdir/config/$f
AC_MSG_RESULT(found)
break
fi
@@ -288,7 +288,7 @@ dnl
AC_SUBST(H5TOH4)
H5TOH4=h5toh4
AC_SUBST(TESTH5TOH4)
-TESTH5TOH4=testh5toh4
+TESTH5TOH4='$(srcdir)/testh5toh4'
AC_ARG_WITH(hdf4,[ --with-hdf4=INC,LIB Use the HDF4 library],,withval=yes)
case $withval in
@@ -734,10 +734,18 @@ else
fi
AC_SUBST(ROOT) ROOT=`$pwd`
-dnl Touch the time-stamp files for src/H5config.h.in and src/H5config.h
-dnl before we generate them or the Makefiles.
-touch ./config/stamp1 ./config/stamp2
+dnl Some cleanup stuff
+rm -f conftest conftest.o conftest.c dummy.o
+dnl Build config.status, then touch the stamp files, then build all
+dnl the Makefiles. The order is such that the first `make' does not
+dnl need to call config.status.
+no_create=yes
AC_OUTPUT(config/depend config/commence config/conclude \
Makefile src/Makefile pablo/Makefile test/Makefile \
testpar/Makefile tools/Makefile examples/Makefile)
+sleep 1
+mkdir ./config >/dev/null 2>&1
+touch ./config/stamp1 ./config/stamp2
+sleep 1
+${CONFIG_SHELL-/bin/sh} $CONFIG_STATUS || exit 1