summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorRobb Matzke <matzke@llnl.gov>1998-04-09 20:22:11 (GMT)
committerRobb Matzke <matzke@llnl.gov>1998-04-09 20:22:11 (GMT)
commitc96611f8b54caf83b386e78ebb398d3a69be752a (patch)
tree55a6e8e66c4e099dec84bb52eca725b9bae00d27 /configure.in
parentc01750fa740943c0083711b353278143c79d50a3 (diff)
downloadhdf5-c96611f8b54caf83b386e78ebb398d3a69be752a.zip
hdf5-c96611f8b54caf83b386e78ebb398d3a69be752a.tar.gz
hdf5-c96611f8b54caf83b386e78ebb398d3a69be752a.tar.bz2
[svn-r339] Changes since 19980408
---------------------- ./src/H5Osdspace.c ./html/H5.format.html In the past we were allowed to have >2GB files on a 32-bit machine as long as no dataset within the file was larger than 4GB (or whatever sizeof(size_t) is). That's been fixed now. All dataset size calculations are done with `hsize_t' which is normally defined as `unsigned long long'. ./src/H5F.c ./src/H5Ffamily.c ./src/H5Fprivate.h ./src/H5P.c ./src/H5Ppublic.h The file family member size can now be set/queried. The default is still 64MB, but it can be set to 1GB by saying: H5Pset_family (plist, 30, H5P_DEFAULT); When opening an existing file family the specified bits-per-member is ignored and the first member of the family determines the bits-per-member, which can be retrieved with H5Pget_family(). ./acconfig.h ./configure.in ./src/H5config.h ./src/H5public.h Added `--disable-hsizet' so that those with old GCC compilers (<2.8.1) can still compile the code. ./src/H5.c ./src/H5private.h Added HDfprintf() which works just like fprintf() except you can give `H' as a size modifier for the integer conversions and supply an `hsize_t' or `hssize_t' argument without casting it. For instance: hsize_t npoints = H5Sget_npoints(space); HDfprintf(stdout,"Dataset has %Hd (%#018Hx) points\n", npoints, npoints); You can now give `%a' as a format to print an address, but all formating flags are ignored and it causes the return value of HDfprintf() to not include the characters in the address (but who uses the return value anyway :-). Example: H5G_t *grp; HDfprintf(stdout, "Group object header at %a\n", &(grp->ent.header)); Added HDstrtoll() which works exactly like [HD]strtol() except the result is an int64. ./src/debug.c Large addresses can now be entered from the command-line. Use either decimal, octal (leading `0') or hexadecimal (leading `0x') when giving the address. ./src/h5ls.c The printf format for dataset dimensions was changed to `%Hu' to support large datasets. ./test/big.c [NEW] A test for big datasets on 32-bit machines. This test is not run by default. Don't try to run it on an nfs-mounted file system or other file system that doesn't support holes because it creates two 32GB datasets of all zero.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in48
1 files changed, 30 insertions, 18 deletions
diff --git a/configure.in b/configure.in
index c4a9ef7..e976474 100644
--- a/configure.in
+++ b/configure.in
@@ -136,27 +136,10 @@ AC_CHECK_HEADERS(unistd.h)
dnl ----------------------------------------------------------------------
-dnl Data types.
+dnl Data types and their sizes.
dnl
AC_TYPE_OFF_T
AC_TYPE_SIZE_T
-
-
-
-dnl ----------------------------------------------------------------------
-dnl Check for functions.
-dnl
-AC_CHECK_FUNCS(getpwuid gethostname system)
-
-AC_TRY_COMPILE([#include<sys/types.h>],
- [off64_t n = 0;],
- AC_CHECK_FUNCS(lseek64 fseek64),
- AC_MSG_RESULT([skipping test for lseek64() and fseek64()]))
-
-
-dnl ----------------------------------------------------------------------
-dnl Check sizes of various integral data types.
-dnl
AC_C_BIGENDIAN
AC_CHECK_SIZEOF(short, 2)
AC_CHECK_SIZEOF(int, 4)
@@ -170,6 +153,35 @@ cat >>confdefs.h <<\EOF
EOF
AC_CHECK_SIZEOF(off_t, 4)
+AC_ARG_ENABLE(hsizet,
+ [--disable-hsizet Datasets can normally be larger than memory
+ and/or files but some compilers are unable to
+ handle this (including versions of GCC before
+ 2.8.0). Disabling the feature causes dataset
+ sizes to be restricted to the size of core memory,
+ or 'size_t'.],
+ HSIZET=$enableval)
+AC_MSG_CHECKING(for sizeof hsize_t and hssize_t)
+case $HSIZET in
+ no|small)
+ AC_MSG_RESULT(small)
+ ;;
+ *)
+ AC_MSG_RESULT(large)
+ AC_DEFINE(HAVE_LARGE_HSIZET)
+ ;;
+esac
+
+
+dnl ----------------------------------------------------------------------
+dnl Check for functions.
+dnl
+AC_CHECK_FUNCS(getpwuid gethostname system)
+
+AC_TRY_COMPILE([#include<sys/types.h>],
+ [off64_t n = 0;],
+ AC_CHECK_FUNCS(lseek64 fseek64),
+ AC_MSG_RESULT([skipping test for lseek64() and fseek64()]))
dnl ----------------------------------------------------------------------