summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorAlbert Cheng <acheng@hdfgroup.org>2000-03-26 14:41:57 (GMT)
committerAlbert Cheng <acheng@hdfgroup.org>2000-03-26 14:41:57 (GMT)
commitefe70a0ee6d691f837c9f05c56131f93d23c0448 (patch)
treed45f71096e3e66f58a1dabefc336154e012cab90 /configure.in
parentd5a38ca39d79e00a1a2595d91f77532c4d4519f6 (diff)
downloadhdf5-efe70a0ee6d691f837c9f05c56131f93d23c0448.zip
hdf5-efe70a0ee6d691f837c9f05c56131f93d23c0448.tar.gz
hdf5-efe70a0ee6d691f837c9f05c56131f93d23c0448.tar.bz2
[svn-r2060] Configure.in:
Changed the defaults of enable-production to off (-g on), enable-debug to on and enable-trace to on. They should be switched to on, off and off respectively when it is time for a release, and then switched back. Yes, lots of work but the debugging helps finding bugs and slows down the speed. configure: Derived from configure.in by autoconf. Platforms tested: IRIX64 (modi4) and Solaris 2.6(baldric).
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in10
1 files changed, 5 insertions, 5 deletions
diff --git a/configure.in b/configure.in
index 77dad3d..e089feb 100644
--- a/configure.in
+++ b/configure.in
@@ -137,13 +137,13 @@ AC_ARG_ENABLE(production,
[ --enable-production Determines how to run the compiler.])
case "X-$enable_production" in
- X-|X-yes)
+ X-yes)
AC_MSG_RESULT("production")
CONFIG_MODE=production
CFLAGS="$CFLAGS $PROD_CFLAGS"
CPPFLAGS="$CPPFLAGS $PROD_CPPFLAGS"
;;
- X-no)
+ X-|X-no)
AC_MSG_RESULT("development")
CONFIG_MODE=development
CFLAGS="$CFLAGS $DEBUG_CFLAGS"
@@ -515,7 +515,7 @@ AC_ARG_ENABLE(debug,
AC_SUBST(DEBUG_PKG)
all_packages="ac,b,d,e,f,g,hg,hl,i,mf,mm,o,p,s,t,v,z"
-if test Xyes = "X$DEBUG_PKG"; then
+if test X = "X$DEBUG_PKG" -o Xyes = "X$DEBUG_PKG"; then
DEBUG_PKG="d,e,f,g,hg,i,mm,o,p,s,t,v,z"
CPPFLAGS="$CPPFLAGS -UNDEBUG"
AC_MSG_RESULT(default ($DEBUG_PKG))
@@ -523,7 +523,7 @@ elif test Xall = "X$DEBUG_PKG"; then
DEBUG_PKG=$all_packages
CPPFLAGS="$CPPFLAGS -UNDEBUG"
AC_MSG_RESULT(all ($DEBUG_PKG))
-elif test X = "X$DEBUG_PKG" -o Xno = "X$DEBUG_PKG" -o Xnone = "X$DEBUG_PKG"; then
+elif test Xno = "X$DEBUG_PKG" -o Xnone = "X$DEBUG_PKG"; then
AC_MSG_RESULT(none)
DEBUG_PKG=
CPPFLAGS="$CPPFLAGS -DNDEBUG"
@@ -546,7 +546,7 @@ AC_ARG_ENABLE(trace,
TRACE=$enableval)
AC_SUBST(TRACE_API)
-if test Xyes = "X$TRACE"; then
+if test X = "X$TRACE" -o Xyes = "X$TRACE"; then
AC_MSG_RESULT(yes)
TRACE_API=yes
CPPFLAGS="$CPPFLAGS -DH5_DEBUG_API"