summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorAlbert Cheng <acheng@hdfgroup.org>1999-02-16 23:07:36 (GMT)
committerAlbert Cheng <acheng@hdfgroup.org>1999-02-16 23:07:36 (GMT)
commit8ed6e885439d7acd4f68e078b1f3dc221e15fc0b (patch)
treeee018dc3804160786556b58a2c511f61333d6d46 /configure.in
parentbbc530781915d52a0420266821e5556dd0736f3d (diff)
downloadhdf5-8ed6e885439d7acd4f68e078b1f3dc221e15fc0b.zip
hdf5-8ed6e885439d7acd4f68e078b1f3dc221e15fc0b.tar.gz
hdf5-8ed6e885439d7acd4f68e078b1f3dc221e15fc0b.tar.bz2
[svn-r1070] Updated to do auto-configuration for parallel tests (testpar)
too. Also used mpi function calls to test mpi libraries. Tested on O2K platform.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in10
1 files changed, 8 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 7ad5f34..daa070f 100644
--- a/configure.in
+++ b/configure.in
@@ -488,6 +488,7 @@ AC_ARG_ENABLE(parallel,
AC_MSG_CHECKING(for parallel support);
AC_SUBST(RUNSERIAL)
AC_SUBST(RUNPARALLEL)
+AC_SUBST(TESTPARALLEL)
if test "mpicc" = "$CC_BASENAME" -a "X-" = "X-$PARALLEL"; then
PARALLEL=mpio
@@ -508,8 +509,8 @@ case "X-$PARALLEL" in
# list also so we don't have to ifdef out the whole file.
AC_MSG_RESULT(mpio)
AC_DEFINE(HAVE_PARALLEL)
- AC_CHECK_LIB(mpi,main) dnl Replace `main' with some function
- AC_CHECK_LIB(mpio,main) dnl Replace `main' with some function
+ AC_CHECK_LIB(mpi,MPI_Init)
+ AC_CHECK_LIB(mpio,MPI_File_open)
if test "X-" = "X-$RUNSERIAL" -o "X-none" = "X-$RUNSERIAL"; then
RUNSERIAL=
fi
@@ -518,6 +519,11 @@ case "X-$PARALLEL" in
elif test "X-none" = "X-$RUNPARALLEL"; then
RUNPARALLEL=
fi
+ if test "X-" = "X-$TESTPARALLEL"; then
+ TESTPARALLEL="testpar"
+ elif test "X-none" = "X-$TESTPARALLEL"; then
+ TESTPARALLEL=
+ fi
;;
*)