summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorRobb Matzke <matzke@llnl.gov>1999-02-26 19:58:14 (GMT)
committerRobb Matzke <matzke@llnl.gov>1999-02-26 19:58:14 (GMT)
commit912c5a0874182f0705e3fe6756859817e2a64cdd (patch)
treea68f01992ce5a618dfee8f69778e2ffd8dda03af /configure.in
parentefb18f8785f0c1f967743fba1ed13a392a0ca601 (diff)
downloadhdf5-912c5a0874182f0705e3fe6756859817e2a64cdd.zip
hdf5-912c5a0874182f0705e3fe6756859817e2a64cdd.tar.gz
hdf5-912c5a0874182f0705e3fe6756859817e2a64cdd.tar.bz2
[svn-r1108] Changes since 19990225
---------------------- ./INSTALL Added warnings and a disclaimer about GNU, DEC, Irix64, and NT compilers that generate incorrect machine code. ./configure.in ./src/H5private.h Detects and includes <sys/param.h> which is needed on FreeBSD before <sys/proc.h> even though we only really using anything from <sys/proc.h> on the DEC Alpha. ./config/irix64 Turned off warnings for duplicate definitions from the linker because -lnsl on irix has the same stuff in it as -lc. ./config/irix6.x Split up the CC and CFLAGS settings like with irix64 so that compilers besides `-n32' can be used. ./bin/snapshot The snapshots are tagged with names like hdf5-1_1_52 which is similar to the way the releases are tagged (cvs doesn't allow dots in tags). ./test/dtypes.c ./src/H5private.h ./src/H5Tconv.c Fixed some alignment violations on the DEC when using high optimization levels. The DEC incorrectly optimizes certain memcpy() and memmove() calls when the source argument is not word aligned if the call looks like it's copying an atomic data type. ./test/hyperslab Worked around code generation bugs in the Irix64 Mongoose 7.00 compiler by casting some `unsigned long' values to `unsigned' in an expression. ./src/H5Ocomp.c Fixed a place where %d was used to print a size_t.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index daa070f..e11fb3b 100644
--- a/configure.in
+++ b/configure.in
@@ -143,7 +143,7 @@ AC_HEADER_STDC
AC_HEADER_TIME
dnl Unix
AC_CHECK_HEADERS(sys/resource.h sys/time.h unistd.h sys/ioctl.h sys/stat.h)
-AC_CHECK_HEADERS(stddef.h)
+AC_CHECK_HEADERS(stddef.h sys/sysinfo.h sys/proc.h sys/param.h)
dnl Windows
AC_CHECK_HEADERS(io.h winsock.h sys/timeb.h)
@@ -348,7 +348,7 @@ dnl ----------------------------------------------------------------------
dnl How do we figure out the width of a tty in characters?
dnl
AC_CHECK_FUNCS(_getvideoconfig gettextinfo GetConsoleScreenBufferInfo)
-AC_CHECK_FUNCS(_scrsize ioctl compress2)
+AC_CHECK_FUNCS(_scrsize ioctl compress2 setsysinfo)
AC_MSG_CHECKING(for struct videoconfig)
AC_TRY_COMPILE(,[struct videoconfig w; w.numtextcols=0;],