summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorRobb Matzke <matzke@llnl.gov>1999-03-04 20:22:42 (GMT)
committerRobb Matzke <matzke@llnl.gov>1999-03-04 20:22:42 (GMT)
commit96320e69c087ff011370a3f070500fa1f9a52a23 (patch)
tree55bb69ebdf807e94833ebb612035910797028f85 /configure.in
parent25421a64fd4413a4ff4bccb7c3137f0abdb8a36e (diff)
downloadhdf5-96320e69c087ff011370a3f070500fa1f9a52a23.zip
hdf5-96320e69c087ff011370a3f070500fa1f9a52a23.tar.gz
hdf5-96320e69c087ff011370a3f070500fa1f9a52a23.tar.bz2
[svn-r1117] Changes since 19990303
---------------------- ./configure.in ./configure [REGENERATED] The path for a command is calculated explicitly the hard way because `type -path' isn't portable. ./config/freebsd ./config/linux-gnu ./config/linux-gnulibc2 Changed the way files reference each other. ./config/gnu-flags [NEW] ./config/dec-flags [NEW] These files figure out what flags to pass to certain compilers so we can reuse code in more than one config/* file. They also have better warning messages when old compilers are used. ./config/linux-gnulibc1 ./config/dec-osf4.x These files use the new *-flags files. ./src/H5D.c ./src/H5Onull.c ./src/H5Tconv.c ./tools/h5ls.c Fixed a compiler warning. ./src/H5detect.c Added a better comment to the top of the generated file.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in24
1 files changed, 18 insertions, 6 deletions
diff --git a/configure.in b/configure.in
index 52673d0..8f50572 100644
--- a/configure.in
+++ b/configure.in
@@ -559,15 +559,27 @@ case "$CC_BASENAME" in
# exists.
PARALLEL=yes
AC_MSG_CHECKING(for mpirun)
- CC_path=`type -path $CC`
- CC_path=`echo $CC_path |sed -e 's/\/mpicc$//'`
- if test -x $CC_path/mpirun; then
- AC_MSG_RESULT($CC_path/mpirun)
+
+ # Find the path where mpicc is located.
+ cmd=`echo $CC |cut -f1 -d' '`
+ if (echo $cmd |grep / >/dev/null); then
+ path="`echo $cmd |sed 's/\(.*\)\/.*$/\1/'`"
+ else
+ for path in `echo $PATH |tr : ' '`; do
+ if test -x $path/$cmd; then
+ break;
+ fi
+ done
+ fi
+
+ # Is there an mpirun at that path?
+ if test -x $path/mpirun; then
+ AC_MSG_RESULT($path/mpirun)
if test "X-" = "X-$RUNSERIAL"; then
- RUNSERIAL="$CC_path/mpirun -np 1"
+ RUNSERIAL="$path/mpirun -np 1"
fi
if test "X-" = "X-$RUNPARALLEL"; then
- RUNPARALLEL="$CC_path/mpirun -np \$\${NPROCS:=2}"
+ RUNPARALLEL="$path/mpirun -np \$\${NPROCS:=2}"
fi
else
AC_MSG_RESULT(none)